OSPF routing is not working properly.

Unanswered Question
Mar 9th, 2009

1. router-2 is head office router.

2. router-1 is one location directly connected with leased line.

3. ospf routing is not working.thats why default routing is used in the configuration(find attachment).

4. Show command result of router-1 is shown in attachmnet.

kindly help me in this mattaer so that i can use my ospf configuration with out defualt routing.

Regards,

Siddhartha

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 03/09/2009 - 03:44

Hello Siddharta,

you need to decide if you want to have OSPF running only on the GRE tunnel you need to remove the network command con the ip subnet of the serial link.

In fact you have:

network 10.10.54.0 0.0.0.255 area 0

that is the WAN interface to HQ

network 192.168.10.0 0.0.0.255 area 0

on R2 router under ospf I don't see the

network 192.168.10.0 0.0.0.255 area 0

there is

network 192.168.0.0 0.0.0.255 area 0

and

network 10.10.54.0 0.0.0.255 area 0

I would do the following changes

remove on both routers

network 10.10.54.0 0.0.0.255 area 0

add on R2

network 192.168.10.0 0.0.0.255 area 0

this creates an OSPF adj on the GRE tunnel.

Otherwise you could risk negative effects in having ospf enabled on both the GRE logical link and the physical link

to troubleshoot OSPF adjacencies you can use:

terminal monitor

debug ip ospf adj

Hope to help

Giuseppe

Actions

This Discussion