Dynamic routing: flapping and/or packet loss

Unanswered Question
Mar 9th, 2009

Hi.

Several of my customers pay for redundant connections to our datacenter. At the customer end is an 1812, setup with EIGRP towards our core 6509.

EIGRP works fine as long as the primary link falls down neatly. The problem is those occurences when the primary link either has packet loss or is in a flapping state (the flapping state isn't noticed on the physical layer of any of the devices under my control, as the flapping is happening somewhere in the cloud of the link provider).

Is there any way I can setup the 1812 and the 6509 to notice packet loss/flapping on the primary link and prefer the secondary link as long as the primary link is in such a state?

Kind regards,

Ivar

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
JamesLuther Mon, 03/09/2009 - 06:08

Hello,

What do you have set for your EIGRP weights ie

router eigrp 88

metric weights tos K1 K2 K3 K4 K5

The K4 value measures reliability, this may work for you?

Regards

ivarstrandberg Mon, 03/09/2009 - 06:51

I haven't set "metric weights" in my EIGRP-config.

Does the "metric weights" feature monitor reliability, or is it just static values?

I can't tell the router that the primary link isn't realiable, as it is reliable until it starts flapping/gets packet loss, and I want that to be detected by the router so that the secondary link is preferred until the primary link is fine again.

Which link will be affected by flapping/packet loss I can't know in advance =)

Giuseppe Larosa Mon, 03/09/2009 - 06:30

Hello Ivar,

check for BFD support: Bidirectional forwarding detection could help

BFD can provide its services to routing protocols

But I don't know if 1812 can support it

see

http://www.cisco.com/en/US/docs/ios/12_4t/ip_route/configuration/guide/t_bfd.html

for example BFD echo detection is supported on

c1805-advipservicesk9-mz.124-24.T.bin

So this is a method you can investigate

Hope to help

Giuseppe

ivarstrandberg Tue, 03/10/2009 - 01:37

Hi. 1812 supports BFD, and I've just setup up two 1812 with redundant links, EIGRP and BFD in my lab, like this:

interface FastEthernet0

ip address 10.10.10.1 255.255.255.252

duplex auto

speed auto

bfd interval 50 min_rx 50 multiplier 3

!

interface FastEthernet1

ip address 10.20.20.1 255.255.255.252

delay 70000

duplex auto

speed auto

bfd interval 50 min_rx 50 multiplier 3

!

router eigrp 1

passive-interface default

no passive-interface FastEthernet0

no passive-interface FastEthernet1

network 10.1.1.0 0.0.0.255

network 10.10.10.0 0.0.0.3

network 10.20.20.0 0.0.0.3

bfd interface FastEthernet0

bfd interface FastEthernet1

auto-summary

!

end

In between the 1812s, on the FA0-link, I've put in a Network Nightmare to make packet loss on the link. With little packet loss (0,5%), neither EIGRP nor BFD notice any problems. With a lot of packet loss (5%), EIGRP goes up and down, and so does BFD...

I expected that BFD would tell EIGRP that the FA0-link isn't reliable while there is packet loss, so EIGRP would prefer FA1...but that doesn't seem to happen.

diepes Mon, 04/05/2010 - 01:46

I am also intrested inways of detecting, reporting and woking around problematic links that do not go down completely.

looking at BDF is seems to be just a way of quickly detecting and reporting link failure and not a general quality measurement.

Have you tested the first suggestion of using the EIGRP link quality to change the routing cost ?

Actions

This Discussion