xconnect between different vlans

Answered Question
Mar 9th, 2009

can I use xconnect session between two routers that have interfaces in different VLANs. On one side it is vlan 154 and on the other xconnect is terminated on interface that is in vlan 144?

I have this problem too.
0 votes
Correct Answer by Harold Ritter about 7 years 7 months ago


I quickly checked with the Feature Navigator and it appears that VLAN ID Rewrite feature is supported only in 12.4T.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
JamesLuther Tue, 03/10/2009 - 01:48


I agree with hritter.

It works in the same way as if you connected a cable between the two VLANs, if that's what you really want to do?

Please post your xconnect config for both sides. Is it AToM or L2TPv3?


draganskundric Tue, 03/10/2009 - 03:38

router a

interface GigabitEthernet0/0.55

encapsulation dot1Q 155

xconnect 55 pw-class class


router b

interface GigabitEthernet0/0.55

encapsulation dot1Q 55

xconnect 55 pw-class class


so if I have same vlan on both sides, then it is ok, but if I change vlan on one side, then it does not work

Harold Ritter Tue, 03/10/2009 - 06:11


Do you use a 7200 at both end? The 7200 platform does support vlan rewrite automatically. There is no need for special configuration. How did you test that it does or does not work? When you changed the vlan on the 7200 did you also changed it on the CE?

Can you post a "show mpls l2 vc detail"


draganskundric Tue, 03/10/2009 - 06:19

yes and yes I've changed it on all nesessary places. How to configure vlan rewrite? I do not have this mpls command

Harold Ritter Tue, 03/10/2009 - 06:43


As I stated in my previous post, there is no command to enable vlan rewrite on the 7200. it is done by default.

Can you please post the output requested and also let us know what level of code you are running on the 7200s.


draganskundric Tue, 03/10/2009 - 06:45

i cannot post you an ouput because I do not have command you are talking about. Ios is c7200-ik9o3s-mz.124-12c

Harold Ritter Tue, 03/10/2009 - 06:53


Here is the command from a device with the same train you are running:

CE1#sh mpls ?

forwarding-table Show the Label Forwarding Information Base (LFIB)

interfaces Per-interface MPLS forwarding information

ip MPLS IP information

l2transport MPLS circuit transport info

label Label information

ldp Label Distribution Protocol information

static Show MPLS static information

traffic-eng Traffic engineering information

CE1#sh mpls l2 ?

binding Display VC label binding information

hw-capability Show MPLS L2 transport capability

summary Show summary of l2transport

vc Display VC(s) info for circuit transport over MPLS

CE1#sh mpls l2 vc ?

<1-4294967295> VC ID or min VC ID value

destination Destination address of the VC

detail Detailed information

interface Local interface of the VC

vcid VC ID or min-max range of the VC IDs

| Output modifiers

CE1#sh mpls l2 vc


draganskundric Mon, 03/16/2009 - 03:46

sorry, it is working, I had to turn off spanning tree for these vlans. thanks for help


This Discussion