3550 Switch and any other device with multiple VLANS

Answered Question
Mar 9th, 2009

We have 3550 switch that is connected to another HP 2524 switch. On the 2524 switch we have several PCs that are on different VLANS. After a power off and on of the 3550, the PC are acting very strange. One might be able to access the Internet but not the Intranet, another may be exactly the opposite but be on the same VLAN. As soon as we remove the 2524 swith and put a hub in place all it well with all PCs on each VLAN. We put in an unmanaged Allied Telesyn switch and the PC act strange again. Below is the configuration of the port the HP or Allied switches are being plugged into.

switchport access vlan dynamic

switchport trunk encap dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport nonegotiate

spanning-tree portfast

This is the running config on the 3550 is exactly the same as before it was powered off.

I am desperate for a resolution.

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 7 years 9 months ago

"Can it be changed on just that one port such as

switchport trunk native vlan 1"

Yes altho the default native vlan is vlan 1 anyway so under the interface

int fa0/13

no switchport trunk native vlan 2

then do a "sh int trunk" again and you should see native vlan as 1.

If you're unsure just post "sh int trunk" again after executing the command.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Mon, 03/09/2009 - 09:51

Ronald

Firstly you shouldn't have "spanning-tree portfast" on this link.

Are you seeing any log messages on the 3550.

Can you post the output of "sh int trunk".

The vlans that are on the 2524 switch, which switch is the STP root for these vlans.

You have a native vlan of 2 - is this what has been set on the other switch.

Jon

ronald.lawrimore Mon, 03/09/2009 - 09:57

Here is the output of sho int trunk

Port Mode Encapsulation Status Native vlan

Fa0/13 on 802.1q trunking 2

Fa0/19 on 802.1q trunking 2

Gi0/1 desirable n-isl trunking 1

Port Vlans allowed on trunk

Fa0/13 1-4094

Fa0/19 1-4094

Gi0/1 1-4094

Port Vlans allowed and active in management domain

Fa0/13 1-6,8,34,234

Fa0/19 1-6,8,34,234

Gi0/1 1-6,8,34,234

Port Vlans in spanning tree forwarding state and not pruned

Fa0/13 1-6,8,34,234

Fa0/19 1-6,8,34,234

Gi0/1 1-6,8,34,234

I am sorry, the HP switch was an unmanaged switch as well, a HP 2124. It is plugged into Fa0/13 on the 3550

Jon Marshall Mon, 03/09/2009 - 10:01

If it's unmanaged it is unlikely to be using vlan 2 as it's native vlan. Can you change the native vlan to vlan 1 on your 3550.

Are you seeing anything in the logs.

Jon

ronald.lawrimore Mon, 03/09/2009 - 10:07

I can test the native VLAN. Can it be changed on just that one port such as

switchport trunk native vlan 1

Here is what is in my log file.

000163: Mar 5 20:36:27: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEth ernet0/13, changed state to up

000164: Mar 5 20:36:27: %SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsist ent peer vlan id 1 on FastEthernet0/11 VLAN2.

000165: Mar 5 20:36:27: %SPANTREE-2-BLOCK_PVID_PEER: Blocking FastEthernet0/13 on VLAN0001. Inconsistent peer vlan.

000166: Mar 5 20:36:27: %SPANTREE-2-BLOCK_PVID_LOCAL: Blocking FastEthernet0/13 on VLAN0002. Inconsistent local vlan.

000167: Mar 5 20:36:42: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthern et0/13 on VLAN0001. Port consistency restored.

000168: Mar 5 20:36:42: %SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthern et0/13 on VLAN0002. Port consistency restored.

000169: Mar 5 20:41:11: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEth ernet0/11, changed state to down

Correct Answer
Jon Marshall Mon, 03/09/2009 - 10:11

"Can it be changed on just that one port such as

switchport trunk native vlan 1"

Yes altho the default native vlan is vlan 1 anyway so under the interface

int fa0/13

no switchport trunk native vlan 2

then do a "sh int trunk" again and you should see native vlan as 1.

If you're unsure just post "sh int trunk" again after executing the command.

Jon

Actions

This Discussion