req help: mwi light on sip trunk

Answered Question
Mar 9th, 2009

Cisco 2651XM router connected to the internet

IOS: c2600-adventerprisek9-mz.124-15.T8.bin

7940G ip phone

sip trunk working fine

I've been nutting away at this problem for days without success, which is that I can't get the mwi light to function on my ip phone.

I have a sip trunk running on my router which works fine for outgoing and incoming pstn calls. Attached is a copy of the phone section of my running config. At the moment when I get a sip call ephone 3 rings which is the way I want it but I also want ephone 3 to display the mwi light when I have a message waiting in my voicemail.

I've done 'debug mwi-relay events' and when the sip trunk first registers I can see the NOTIFY message from my sip provider but I've been unable to get my phone to work the mwi light.

If anyone can look at the config and tell me what I need to do to make this work that'd be great.

thanks for any pointers.

Attachment: 
I have this problem too.
0 votes
Correct Answer by ebreniz about 7 years 10 months ago

You have one of two options to fix this problem:

1. You can get your mwi server to add 8000 or 8001 in front of the extention that is located in the To: header of your NOTIFY message.

2. Change your mwi on and off dn so that it will reflect whatever extension that you are expecting in the NOTIFY message.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
ebreniz Fri, 03/13/2009 - 06:43

You have one of two options to fix this problem:

1. You can get your mwi server to add 8000 or 8001 in front of the extention that is located in the To: header of your NOTIFY message.

2. Change your mwi on and off dn so that it will reflect whatever extension that you are expecting in the NOTIFY message.

tonyspcrepairs Fri, 03/13/2009 - 08:58

thanks for your response. Your suggestion #2 worked. I used 'mwi sip' under the sip number dn and the mwi light finally came on.

Actions

This Discussion