E.164 Dialing from phone directory + CUCM 6.1

Unanswered Question
Mar 9th, 2009
User Badges:


We are using our Corporate LDAP Directory for IP phone directory lookup.

ie: 3rd party web server publishing the users phone dumber in the E.164 format.

We want to have our users dial this number using the dial key on the phone when displayed. I was hoping a translation pattern or route pattern on CUCM 6.1 would work but it doesnt support this. I am aware CUCM 7.X does support E.164 dialing however I am hoping someone out there has got a potential workaround on CUCM 6.1.2

eg: User displayed +64488552211 must then be converted to 10488552211 for the user to dial

We are hoping not to change the application, ideally have the CUCM do the conversion



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
d.haeni Tue, 03/10/2009 - 15:09
User Badges:

Hi Steve,

I just had a look on how we have solved your issue at the 6.x time internally (In the meantime we are on 7.x).

You'll need a translation pattern als follows ("\" as an escape character):

\+64.! (or similar, according to your needs)

then in the called party transformation

- Discard PreDot

- Prefix Digits 10

Hope this gets you on the right track.



Jaime Valencia Tue, 03/10/2009 - 18:11
User Badges:
  • Cisco Employee,
  • Hall of Fame,


u know for a fact that works?? have u seen it work? \ is not a valid character for a pattern, i knew it wasn't but just to make sure i tried your pattern on a 6.1(3) and i cannot save it. i get the message saying what digits/characters are valid and \ is not one of them.

the usage of + in any previous version other than 7 means:

matches one or more occurrences of the preceding digit or wildcard value

These are the ONLY valid entries you can have in a translation pattern:

[ ^ 0 1 2 3 4 5 6 7 8 9 A B C D - ] + ? ! X * # + . @



if this helps, please rate

steve-parrish Tue, 03/10/2009 - 18:24
User Badges:


You'll need a translation pattern als follows ("\" as an escape character

is not available on cucm 6.1



d.haeni Wed, 03/11/2009 - 00:34
User Badges:

Sorry Steve,

I didn't research well enough. The translation pattern I mentioned is only available in CUCM 7.x

However, we were able to solve the issue that you are mentioning in the following fashion:

- The Pre-8.4 phone loads did simply ignore the "+" sign within the Corporate Directory E.164 number. A simple translation from the leading "64" to "10" should therefore do the job

- The 8.3(4)SR2 is the release we're using. The "+" digit was honoured as of 8.4 firmware, but the CUCM 6.x is not supporting it. If I'm not mistaken you should be on 8.3 firmware with 6.1(2)

steve-parrish Wed, 03/11/2009 - 02:08
User Badges:

yes we were aware of this however it doesnt meet out call routing design (ie: TP's and RP's)

Thank you for looking into this, it will aanother reason to move to CUCM 7



Tommer Catlin Wed, 03/11/2009 - 08:17
User Badges:
  • Green, 3000 points or more

So in CUCM 6.x, the + is not a digit, so the translation, even in the latest firmware the phones and cucm 6.x,. Same thing in CUPS for click to call in Application Dial Rules. The + is ignored in CUCM 6.x. When you think it's 12 digits, it's not.. it's 11.

+1 408 555 1212


This Discussion