BGP Multihome/Failover Scenario

Answered Question

Hi All,

I have the following situation as per attached 'mock setup'diagram.Currently all traffic is using R1 as the primary connection.R1 also has memory issues so I want to move traffic over on to R2 with the minimum amount of disruption the environment attached !Currently R1 is displaying the typical problems associated with memory issues so the CLI is non responsive to some commands and it is not recommended to make any changes to the config etc. so I'll have to make any necessary changes to R2 for the time being ; unfortunatly I am not in a situation where I can change the memory at the moment. FYI there are two environments/customers sitting behind the switches one which is seperated with vlan100 and the other with vlan150.We currently use 'weight' to influence outbound routing decisions and 'MED' to influence inbound. What is the best config change to accomplish this as seamlessly as possible. I am thinking to change the HSRP priority first to make R2 the master,then adjust the weight and MED on the route-maps of R2? However will this cause the BGP to reconverge so with timers set to 30 90 this will take 90 secs to come back up ? I would also like if someone could explain to me exactly what the Null0 routes accomplish and the same weight of 50 is applied to the route-map ibgp-in? If there are a few scenarios I'd appreciate if you could explain how it will work and the downtime implications. I would also like to know if it would be easy to just get a default route from the ISP but I guess this would involve filtering routes on R1 which is not currently possible ?

Also what does the following regexp ^\(.* mean ? Thanks in advance

I have this problem too.
0 votes
Correct Answer by guruprasadr about 7 years 9 months ago

HI Francis, [Pls RATE if HELPS]

Outboud from LAN is as per HSRP Roles.

Weight is again local to the Router attribute. If you make R1 as Offline Router then Weight has nothing to play.

Best Regards,

Guru Prasad R

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (5 ratings)
Loading.
guruprasadr Tue, 03/10/2009 - 06:29

HI, [Pls RATE if HELPS]

Assuming the below configuration in your Routers.

R1 Router:

==========

neighbor aaa.bbb.ccc.ddd remote-as 2111

neighbor aaa.bbb.ccc.ddd route-map setMED-R2 out

neighbor

route-map setMED-R2 permit 10

match ip address 1

set metric 200

!

R2 Router:

==========

neighbor eee.fff.ggg.hhh remote-as 2111

neighbor eee.fff.ggg.hhh route-map setMED-R3 out

neighbor

route-map setMED-R3 permit 10

match ip address 1

set metric 400

!

MED:

====

A lower MED value is preferred over a higher value.

Modify the MED Value to less than the PRY.

Weight:

========

A higher Weight value is preferred over a lower value.

Modify the Weight Value to Higher than the PRY.

HSRP:

=====

Execute an HSRP Flap to make R2 as Master.

BGP Timer:

==========

You need to wait until the BGP Convergence. FYI: Its not advicable to tune the BGP Timer values.

Regular Expression:

===================

Refer link below:

http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800c95bb.shtml#asregexp

Hope I am Informative.

PLS RATE if HELPS

Best Regards,

Guru Prasad R

Giuseppe Larosa Tue, 03/10/2009 - 06:43

Hello Francis,

unless R2 is more powerful then R1 I would move the traffic of only one customer to R2.

to intercept traffic directed outbound you can increase the HSRP priority and with preempt enable R2 will take over the active role on vlan100.

About the BGP configuration:

because weight commands are kept local (weight is not exported in BGP updates) you only need to articulate the outbound policy so that R2 can become the preferred ingress point for traffic destinated to customer 1.

Each router prefers eBGP routes to iBGP routes (higher weight and also it would be the default behaviour)

the route-map needs to be written in two blocks:

first block will provide MED 80 for customer 1 network

second block will provide MED 200 for customer 2 network

let me suppose

216.104.222.0 is for customer1

access-list 11 permit 216.104.222.0 0.0.0.255

access-list 12 permit 216.104.233.0 0.0.0.255

route-map med-out permit 10

match ip address 11

set metric 80

route-map med-out permit 20

match ip address 12

set metric 200

this to make changes only on R2 as desired

note1:

the two static routes to null0 do nothing because the same subnets are on the Vlan interfaces so you can remove them.

note2: the time it takes to propagate your changes is only for the change outbound on the route-map outbound on R2.

the time it takes is the time to send out the new BGP updates + time to have them processed and propagated on the service provider network (up to 60 seconds) but there is not real out of service R1 is used as preferred ingress point until the change is propagated in SP network

Hope to help

Giuseppe

Hi, Thanks for the reply.R2 has 1GB DRAM so no problems there.So let me get this straight then :

SCENARIO 1:eg Customer 1 VLAN 100 PREFER

1.Increase HSRP Priority to intercept traffic

2.Adjust route-map *also* to prefer R2 for outbound exit

route-map bths-in permit 10

match as-path 4

set weight 300

!

route-map bths-in deny 20

3.Adjust MED also to control what comes in now --> Replace existing route map with below as follows

no neighbor 193.95.147.57 route-map bths-out out

neighbor 193.95.147.57 route-map MED-OUT out

access-list 11 permit 216.104.222.0 0.0.0.255

access-list 12 permit 216.104.233.0 0.0.0.255

route-map med-out permit 10

match ip address 11

set metric 80

route-map med-out permit 20

match ip address 12

set metric 200

*RESULT* --> So will this mean that customer on vlan 100 will prefer R2 now for outbound and inbound traffic and Vlan 150 will continue to use the R1 ?

SCENARIO 2:Make both prefer R2

1.Adjust both HSRP priority/pre-emption

2.Adjust weights and metrics on both existing route maps on R2.

Am I correct in saying as well when you adjust the weights there will not be an outage ever as they are local significant only .With regards to this scenario will R1 continue to be used until change is proapgated so no 'out of service'.

Sorry if a little confused but relatively new to BGP

Giuseppe Larosa Tue, 03/10/2009 - 07:58

Hello Francis,

>> *RESULT* --> So will this mean that customer on vlan 100 will prefer R2 now for outbound and inbound traffic and Vlan 150 will continue to use the R1 ?

yes my suggestion is to have one customer served by R2 and the other served by R1

outbound traffic follows the HSRP roles/priorites (because each router prefers the eBGP routes) inbound traffic prefers router using the lowest MED

scenario2:

all traffic handled by R2:

HSRP active on both vlan 100,150 on R2

MED 80 for both customer networks on R2

Hope to help

Giuseppe

guruprasadr Tue, 03/10/2009 - 08:02

HI Francis, [Pls RATE if HELPS]

In this situation, i would suggest you to make R1 as Offline, since the Router is running with dead memory and as well the CLI access is lost.

Make VLAN 100 & 150 to prefer R2 for both in-bound & out-bound.

1. HSRP active for VLAN 100,150.

2. Outbound is as per HSRP Roles.

3. Inbound is as per the MED Control.

Hope this Helps.

Pls RATE if HELPS

Best Regards,

Guru Prasad R

Correct Answer
guruprasadr Tue, 03/10/2009 - 08:25

HI Francis, [Pls RATE if HELPS]

Outboud from LAN is as per HSRP Roles.

Weight is again local to the Router attribute. If you make R1 as Offline Router then Weight has nothing to play.

Best Regards,

Guru Prasad R

Actions

This Discussion