cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
10155
Views
0
Helpful
1
Replies

IP SLA and IP route tracking

Collin Clark
VIP Alumni
VIP Alumni

Below is my configuration for tracking.

<code>

track 123 rtr 1 reachability

!

interface Vlan1

description primary-link

ip address 10.1.2.71 255.255.255.0

!

interface Vlan2

description backup-link

ip address 192.168.4.254 255.255.255.0

!

ip local policy route-map MY-LOCAL-POLICY

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.1.2.17 track 123

ip route 0.0.0.0 0.0.0.0 192.168.4.5 254

!

ip sla 1

icmp-echo 10.1.2.17

timeout 1000

threshold 2

frequency 3

ip sla schedule 1 life forever start-time now

access-list 101 permit icmp any host 10.1.2.17 echo

!

route-map MY-LOCAL-POLICY permit 10

match ip address 101

set ip next-hop 10.1.2.17

set interface Null0

</code>

<code>

Router#sh ip sla stat

Round Trip Time (RTT) for Index 1

Latest RTT: 1 milliseconds

Latest operation start time: *16:32:49.411 UTC Sun Jul 14 2002

Latest operation return code: OK

Number of successes: 56

Number of failures: 2

Operation time to live: Forever

</code>

<code>

Router#show ip route track-table

ip route 0.0.0.0 0.0.0.0 10.1.2.17 track 123 state is [up]

Router#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.1.2.17 to network 0.0.0.0

10.0.0.0/24 is subnetted, 1 subnets

C 10.1.2.0 is directly connected, Vlan1

S* 0.0.0.0/0 [1/0] via 10.1.2.17

Router#</code>

Once I pull the ethernet cable for the 10.1.2.0 network everything appears to work except for one thing, the routing table.

<code>

Router#

*Jul 14 16:34:44.247: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0, changed state to down

*Jul 14 16:34:44.251: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down

*Jul 14 16:34:45.255: %LINK-3-UPDOWN: Interface FastEthernet0, changed state to down

*Jul 14 16:34:45.807: %TRACKING-5-STATE: 123 rtr 1 reachability Up->Down

Router#show ip route track-table

ip route 0.0.0.0 0.0.0.0 10.1.2.17 track 123 state is [down]

Router#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

Router#</code>

Shouldn't I see the default route set to 192.168.4.5?

1 Reply 1

Collin Clark
VIP Alumni
VIP Alumni

Might help if I bring VLAN2 up. Sorry.