How to disable MOH for "on Hold" button.

Answered Question
Mar 10th, 2009

CUCM 6.1

When on a conference call if a user presses "on Hold" button, music is played for all participants and nobody can hear anything. How can I disable music on hold for all users?

Please note, I could disable MOH for conferencing. But this is different issue. This is e.g. when everyone is in a conference (no matter what conference system, it could be ready talk, meeting place,...)and a participant receives another call and wants to answer the other call, in this situation I don't want any MOH played for other participants.

Thanks,

rdianat

I have this problem too.
0 votes
Correct Answer by Jaime Valencia about 7 years 8 months ago

well that is really something we can't control if the phones are accessing another CFB or another party is the one that puts on hold, it's a stream to the CFB and does not differentiate voice from MOH. the parameter only works for internal phones and internal CFB.

Q. How do I disable Tone on Hold (ToH)?

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_qanda_item09186a0080094766.shtml#q21

HTH

java

if this helps, please rate

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jaime Valencia Tue, 03/10/2009 - 11:27

change this service parameter to true

Suppress MOH to Conference Bridge

HTH

java

if this helps, please rate

rdianat Tue, 03/10/2009 - 12:26

Hi Java,

I actually did this without any effect before posting my question. I learned this from your answers to a previously posted question. There are two problems with this answer:

Your solution will only work if all line and devices are already set to "none" for their MOH settings. Callmanager always read line setting first, then reads device and ... then service parameter. (this is what I read in some MOH FAQ from CCO) So this requires I change all the individual MOH settings on all users to none . But still this is not the issue. The problem is with on-hold music. Just forget about conference. suppose I call you and when you are talking to me when someone else calls you. You answer your other line, I will hear music. How can I eliminate this music. simple beep is fine.

Thanks,

rdianat

Jaime Valencia Tue, 03/10/2009 - 12:39

i've used the parameter before and it does not matter on which of the 4 levels you have the MOH, it's irrelevant

if you don't want someone to hear MOH take the MOH server from the MRGLs

on the scenario you mention i would take the MRGL with MOH server from YOU.

I decide which MOH you will hear, but whether you'll hear it or not depends on if you have access to the MOH server that has the stream.

create a new device pool, assign MRGL with no MOH and use it for your CFB.

HTH

java

if this helps, please rate

rdianat Tue, 03/10/2009 - 13:41

Hi Java,

We are getting close....

if the conference is on our callmanager or meeting place, we do not have any problem. The problem is when different participants like vendors from different companies on different phone system do a conference. for cisco phones when a participant answers another call, the phone goes on-hold and this plays MOH for all participant which is very annoying.

Now I have completely disabled MOH and things look much better, but the customer still wants to completely eliminate those beep-beeps or at least reduce the volume or frequency. Any idea?

Thanks,

Correct Answer
Jaime Valencia Tue, 03/10/2009 - 13:49

well that is really something we can't control if the phones are accessing another CFB or another party is the one that puts on hold, it's a stream to the CFB and does not differentiate voice from MOH. the parameter only works for internal phones and internal CFB.

Q. How do I disable Tone on Hold (ToH)?

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_qanda_item09186a0080094766.shtml#q21

HTH

java

if this helps, please rate

rdianat Wed, 03/11/2009 - 05:46

Disabling TOH is what I was looking for. Thanks for your help Java.

rdianat

FureyaAtaker Mon, 04/13/2009 - 13:47

Quick qestion:

how did you disable MOH for all users on CUCM 6.1?

Set "run flag" to NO on all MoH servers.

rdianat Tue, 04/14/2009 - 12:23

I first tried "suppress MOH for conference" by service--> service parameters -->select server --> select callmanager --> go to "clusterwide parameters(Feature-General) --> change the "Suppress MOH to conference Bridge" to true"

This did not work. The reason is that these users are accessing an internet coferencing system like "ready talk" and not a cisco conferencing system, so for Cisco this does not appear to be a conference but it is like a regular call.

I only have two callmanagers which also serve as MOH servers.

Media Resources-->Music On-Hold Server -->Set Run Flag to "NO"

This is explained in "MOH FAQ" from cisco.

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_qanda_item09186a0080094766.shtml#q21

The other way of doing this is not to assign any MOH server to the MRG or create a device pool without any MOH. (Media Resource Group set to NONE)

Although the above disabled the MOH, still the TOH "Tone on Hold" which is beep-beeps played every 10 seconds was annoying. So I increased the interval to 20 seconds by the same instructions in "MOH FAQ" how to disable / change TOH. Go to same page explained above but to "clusterwide Parameters(Device-General) and change "Tone on Hold Timer" Value to 20.

rdianat

Actions

This Discussion