Etherchannel config not working

Unanswered Question
Mar 10th, 2009
User Badges:

Hi,


I am trying to create an etherchannel between a Cisco 2950 and 3550 in a lab first. I want to use 2 ports on each switch as a trunk for load balance and redundancy.


If I just have one fa0/1 from each switch connected the PC's in fa 0/24 on each switch (VLAN 10) can ping each other as soon as I add the second trunk from fa0/2 on each switch the pings stop and I get the spanning tree blocking one of the ports:


01:11:14: %SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastE thernet0/3 VLAN1.

01:11:14: %SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/3 on VLAN0001. Inconsistent port type.


Please take a look at my simple configs



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
whiteford Tue, 03/10/2009 - 14:58
User Badges:

First mistake:


Received 802.1Q BPDU on non trunk FastE thernet0/3 VLAN1.


I used the wrong port, however does my config look ok for load balance?


As I'm getting this error now:


01:30:08: %PM-4-ERR_DISABLE: channel-misconfig error detected on Fa0/2, putting Fa0/2 in err-disable state


jorge.calvo Tue, 03/10/2009 - 16:01
User Badges:
  • Bronze, 100 points or more

Hello,


Regarding the misconfiguration you have on the channel-group check:


1. You are using the same trunking protocol on both sides, dot1q in this case.


2. The flow-control is the same on both sides. Flowcontrol is off by default, thus the line should not be there.


interface Port-channel1

switchport mode trunk

flowcontrol send off <---


3. Enable trunk only on the Port-channel.


About the load-balance, you left it by default which is source mac-address. The load balancing will depend on the kind of flow that will traverse your Port-channel.


By the way, did you get your ping to work?

glen.grant Tue, 03/10/2009 - 15:45
User Badges:
  • Purple, 4500 points or more

You can't bring them up one at a time . Also my self I would use " channel group X mode desirable non-silent but that is just a preference which lets the switch negotiate the etherchannel. Do a shut on the port channel itself not the interfaces . Then bring up the "port channel" (no shut) which should bring up both interfaces at the same time. Do this for both sides . When you do 1 at a time it treats it as an individual trunk link and then you have a mismatch from the far side of the link and a spanning tree loop so it shuts down 1 port , when you bring the "port channel active " it puts both ports into the port channel and should eliminate the spanning tree blocked port condition .

whiteford Tue, 03/10/2009 - 16:15
User Badges:

Shutting down the port channel and bring it back up fixed it and all is working, I can ping other the devices across the switches even when I pull out the a trunk port or shut it down, so by default is it load balancing?


Can I tell which of the trunks is getting used most?

Actions

This Discussion