IP Phone one stage dialing

Unanswered Question
Mar 10th, 2009
User Badges:

Hello

I have

1) CCM 4.1

2) Cisco IP Phone 7970

There is one route pattern XXXXX which points to voice gateway. There are 4-digit local DNs.


Therefore when I dial local number (e.g. 2001) using ip phone 7970 (DN: 2002), digits goes to CCM one-by-one and I have to wait until T302 (interdigit timeout) expires to get my phonecall processed. If I dial 2001# I hear busy tone right away.

On the contrary, when I dial <redial> button the call establishes immediately (digits does not go to CCM one-by-one).


Well, the question is: Is it possible to make IP phone dial all numbers immediately (one stage dialing)? Why # sign does not help?

Is it necesarry at all for IP telephony to use two stage dialing?

Terms one and two stage dialing taken from here http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a00800e00d0.shtml

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.5 (2 ratings)
Loading.
Eldho E Kuriakose Wed, 03/11/2009 - 00:37
User Badges:
  • Bronze, 100 points or more

create route pattern ending with # , then # will work


Otherwiwise add particular route patterns...

deniska2006 Wed, 03/11/2009 - 01:04
User Badges:

Thank U for cooperation.


1) Added pattern 98XXXXXXXXXXX#

It didn't affect the way 4-digit numbers dialed. # returns busy tone.


2) Changed DN form 2002 to 2002#

Now # sign works, but when I dial 2002 without # - busy tone occurs after T302 timeout (not good).


Any ideas?

Jaime Valencia Wed, 03/11/2009 - 10:32
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

# if not using @ need to be configured on pattern


XXXX won't do

XXXX# works

XXXX@ works


you can dial onhook and then press dial, that avoids IDT. that's the reason why redial works, it's not really sending all digits at once but gives the notification it has dialed all digits.


off-hook dialing is one by one and can only use # to notify you finished dialing


HTH


java


if this helps, please rate

deniska2006 Wed, 03/11/2009 - 20:50
User Badges:

> XXXX won't do

> XXXX# works

> XXXX@ works


4-digit numbers are locally registered IP Phones. Route pattern for 5-digit numbers (XXXXX) points to PBX via Voice GW.


> you can dial onhook and then press dial, that avoids IDT. that's the reason why redial works

When I do so (dial onhook and then press dial) the process goes EXACTLY like off-hook dialing (I hear digits being dialed and then wait for T302 timeout)! ONLY redial works. May firmware be the reason of that problem?

Current firmware is (one of them, not sure which one)

sccp70.8-3-5S

jar70sccp.8-3-4-16.sbn

cvm70sccp.8-3-4-16.sbn

cnu70sccp.8-3-4-16.sbn


jasondrisc Wed, 04/01/2009 - 06:16
User Badges:

Java,


I have a question that I have not been able to find an answer to, I believe you may be able to assist.


If it exists, what is the parameter to extend the "interdigit timeout" while dialing on an idle/onhook phone? Or is this directly related to the T302 parameter?


Thanks,


Jason

Jaime Valencia Wed, 04/01/2009 - 08:39
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    2011

unfortunately that one is not configurable, it's hardcoded in the phone FW and is something like 10s


HTH


java


if this helps, please rate

jasondrisc Wed, 04/01/2009 - 08:43
User Badges:

Thank you for the quick reply although unfortunate info.


Thanks,


Jason

Actions

This Discussion