Quality Manager

Unanswered Question
Mar 11th, 2009
User Badges:

I have installed an AQM version 2.6 with CUCM 7 and UCCX 7.

I have followed the instalation guide but I have some problems, I had some logs from Event viewer but I haven't found any information to fix them.

Logs:

RecordServer: The description for Event ID ( 4 ) in Source ( RecordServer ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: SQMUPLOAD1020 Database error (got -1 dbuid). Unable to update database for callID(16787171) .

.


QM-dbupload:

The description for Event ID ( 4096 ) in Source ( QM-dbupload ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:


QMDB2002 Unexpected DB-API problem: Unable to retrieve ccrId for new item dated <1236770626>.


QM-dbproxy:

The description for Event ID ( 4096 ) in Source ( QM-dbproxy ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:


QMDB2001 SQM database execute failed: Instrucción INSERT en conflicto con la restricción FOREIGN KEY "Ccr_agent_FK". El conflicto ha aparecido en la base de datos "SQMDB", tabla "dbo.Agent", column 'id'..


QM-dbsync:

The description for Event ID ( 4096 ) in Source ( QM-dbsync ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:


QMSY2000 Synchronization of LDAP to the QM Database failed due to: null



DirAccessSynSvr:

The description for Event ID ( 4 ) in Source ( DirAccessSynSvr ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: FCSS-001 failed to synchronize LCC:<Call Center 1>, fcn<SPeripheral::initialize>, problem<sql failure, failed to get agents, peripheral id<pid>>, errcode<-20>


It will be related with this but when I run WFO Desktop and try to log in, I have an error mesage attached. There is not integration with LDAP, user are created on WFO Administration.





Has anyone faced these problem?

Where can I find more info about it?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Mustafa Al Housami Tue, 07/07/2009 - 00:59
User Badges:

hey nlatxiondo

did you solve the problems described above?

i am facing a synchronization issue between QM and uccx


I downloaded the Quality Management Administrator software on my desktop, and logged in. Then while synchronizing databases by clicking on file -> synchronize databases i get an error: ERROR QMAD2003 SyncServer error. See log.

I checked the C:\Program Files\Cisco\WFO_QM\log\dbsync.log file in the QM server and it is displaying that QMSY0000 DB sync terminating successfully.

its weird

Can you help?

Anonymous (not verified) Sun, 08/09/2009 - 06:52
User Badges:


Sheraz Saeed Lodhi Tue, 09/15/2009 - 03:53
User Badges:

this is SQl user issue i faced the same error "ERROR QMAD2003 SyncServer error. See log" but it disappered after i create an SQL user with name "qmuser" and change the password in QM machine.


Now i m facing the issue that wi have added new 40 users License of QM in uccx but it's still not replicating to QM. wen i open QM administrator it doen't display the new one even when i try to register ny user their it won't let me do this.

Michal Kadlec Mon, 05/02/2011 - 02:26
User Badges:

I have QM 2.7.3.12 and UCCX 7 and I had the same issue with synchronization of QM with UCCX database after i did upgrade QM from 2.7.2.9.

I have created new user e.g. ntuser in both UCCX servers and also in QM server. In QM i added them to Administartor group, in UCCX i added the user to CiscoCRSUser group and to Administrator as well, after this synchronization started to work.

caosorio_01 Sat, 06/30/2012 - 10:47
User Badges:

For this error what i had to do is to provide in lower cases the database name, also be carefull because dashes are not accepted, try to use unerscores instead.


Hope this helps.


Caosorio.

Actions

This Discussion