Fax issues on VG224

Unanswered Question
Mar 11th, 2009

I have two fax machines that are connected to a VG224 and both those are having intermittent issues. Incoming fax fails on the remote end and an error is generated but at the remote end but for outgoing fax, no errors are generated. The only way to check if the fax was sent successfully is by calling the customer and asking if the fax was received. Please help.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Paolo Bevilacqua Wed, 03/11/2009 - 12:37

Check that you have:

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

Or change "0" as needed.

Nicholas Matthews Wed, 03/11/2009 - 19:30

What protocol are you using on both the vg224 and the 2800?

If it's H323/SIP/SCCP try this:

voice service voip

fax proto none

modem pass nse code g711u

Check 'show controllers t1' for slips (anything other than 0 in the counters is bad), and check 'show call active voice brief for packet loss or jitter - use attached doc for help).



carlnewton Thu, 03/12/2009 - 05:09

Also ensure that the codec being used for the fax calls is G711 at all stages and the the faxes themselves are not "super G3" or similar enhanced data rate devices.

George Thomas Thu, 03/12/2009 - 06:47

Hello Carl,

The protocol is G.711 at all stages and the faxes are not super G3.

George Thomas Thu, 03/12/2009 - 06:42

Hello Nic,

The VG224 and the gateway uses MGCP. There are no clock slips happening.

George Thomas Thu, 03/12/2009 - 08:52

I have tried calling the fax number and it looks like its hitting the 0/0 dial-peer and not the dial-peer attached to the fax machine. Is this normal? I dont see any jitter, latency, packet drops etc.

Chandramohan Na... Thu, 03/12/2009 - 09:12

I would configure the VG as SCCP instead of MGCP as MGCP gave lots of issues with faxing and after configuring as SCCP no issues. Attached is a sample SCCP configuration.

wilson_1234_2 Thu, 03/12/2009 - 19:21

What do these commands do:

network-clock-participate wic 0

network-clock-select 1 T1 0/0/0

richard.sanchez Thu, 03/12/2009 - 10:24

I had the same problem at our campus, over 30 faxes. We turned OFF the error handling on the TX & RX on the fax. Also chechk the baud rate, we found it worked better at 9600 baud. We 1st found this problem when using ATAs.

Good Luck

p.grace Wed, 04/13/2016 - 18:38

Had similar prob - faxes would work internally but not from external. Main gateway is a 3825 with fax machines hanging off VG224. Turns out that on the 3825 I had set mgcp bind to a loopback rather than to a routable interface. Interface g0/1 was on same VLAN that VG224s were on.

ON 3825:

ip tftp source-interface GigabitEthernet0/1

interface GigabitEthernet0/1
description City Voice gateway
ip address VG224s_VLAN_24bit_mask
no ip proxy-arp
ip nbar protocol-discovery
ip flow ingress
ip flow egress
ip pim sparse-dense-mode
ip virtual-reassembly in
duplex auto
speed auto
media-type rj45

interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn incoming-voice voice
isdn bind-l3 ccm-manager
isdn bchan-number-order ascending
no cdp enable

voice-port 0/0/0:15
cptone AU

ccm-manager fallback-mgcp
ccm-manager redundant-host CALL_MANAGER_FALLBACK_IPs
ccm-manager mgcp
no ccm-manager fax protocol cisco
ccm-manager music-on-hold
ccm-manager config server CALL_MANAGER_SUPERVISOR
ccm-manager config

mgcp call-agent CALL_MANAGER_IP 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 ecm
mgcp fax t38 inhibit
no mgcp explicit hookstate
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface GigabitEthernet0/1
mgcp bind media source-interface GigabitEthernet0/1

mgcp profile default
dial-peer voice 1 pots
service mgcpapp
destination-pattern .T
incoming called-number .T
port 0/0/0:15


This Discussion