IOS SSL VPN client on Vista

Answered Question
Mar 11th, 2009
User Badges:

Hi,

I have set up a SSL VPN on a 877 router. It has been tested working with a XP notebook. Now the notebook has been formatted into Vista and i'm getting such error "The installer was not able to start the Cisco SSL VPN Client.

Please contact your IT administrator for more information. Click here to logout."


I looked up some old info and it seems in the past, SSL VPN client don't work in Vista. However that posting was quite old.


Has anyone manage to get it to work on Vista ?

Correct Answer by s-kirk about 8 years 2 months ago

I had the exact same problem apart from my router was a 2811.


The Cisco SSL VPN client is not supported on any flavour of Vista - you need to upgrade to the Anyconnect client.


I used the anyconnect-win-2.3.0254-k9.pkg


I also found that SDM did not recognise this as a valid SSL client so in order to install I did the following via the cli


1. tftp package to flash of router

2. Uninstall existing client with


no webvpn install svc flash:/webvpn/svc_1.pkg sequence 1


3. Install the new package with


webvpn install svc flash:anyconnect-win-2.3.0254-k9.pkg


After that I reconnected my broken vista client and it worked like a charm.


Plus as I was running 12.4(20)T I am now able to use anyconnect client in standalone mode - ie I do not have to connect via a browser.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Ivan Martinon Thu, 03/12/2009 - 14:34
User Badges:
  • Cisco Employee,

SSL should work with vista, unless the machine is a 64 bit platform, in which case you would need AnyConnect instead of SSL. do you get any specific error from the Vista event viewer you can share?

joelau007 Thu, 03/12/2009 - 15:33
User Badges:

I tried both sslclient-win-1.1.4.179.pkg and sslclient-win-1.1.4.179-anyconnect.pkg Both have the same error on Vista. However they both work on XP. No specific error was found in the Vista event viewer, and my account has local admin rights. I have tested on Vista business and enterprise, same problem.

Regards.

Ivan Martinon Thu, 03/12/2009 - 15:35
User Badges:
  • Cisco Employee,

platform? 64 or 32? Also I am not sure about this on SSL or Anyconnect, I would check the releaes notes to see if the upgrade from XP to vista is supported, I recall that Cisco vpn client did not support this scenario.


joelau007 Thu, 03/12/2009 - 17:08
User Badges:

Vista 32. All the test machines are fresh install, not upgrade.


I just tried connecting from another internet connection, same thing, so it's not related to internet connection.

Regards.

Correct Answer
s-kirk Wed, 03/25/2009 - 19:02
User Badges:

I had the exact same problem apart from my router was a 2811.


The Cisco SSL VPN client is not supported on any flavour of Vista - you need to upgrade to the Anyconnect client.


I used the anyconnect-win-2.3.0254-k9.pkg


I also found that SDM did not recognise this as a valid SSL client so in order to install I did the following via the cli


1. tftp package to flash of router

2. Uninstall existing client with


no webvpn install svc flash:/webvpn/svc_1.pkg sequence 1


3. Install the new package with


webvpn install svc flash:anyconnect-win-2.3.0254-k9.pkg


After that I reconnected my broken vista client and it worked like a charm.


Plus as I was running 12.4(20)T I am now able to use anyconnect client in standalone mode - ie I do not have to connect via a browser.

joelau007 Thu, 03/26/2009 - 19:25
User Badges:

Spot on. anyconnect-win-2.3.0254-k9.pkg fixed the problem.

Actions

This Discussion