Topology Servies seems disable

Unanswered Question
Mar 12th, 2009

Hello;


We use Campus Manager 5.0.4 on LMS 3.0.1. We installed LMS with local admin account. Then we add server to domain.


When we logon server with local admin account, topology services is working properly but with the domain admin account, topology services right click menu and other options comes disable.


We reinstall java but nothing is change. Then we control security permissions on LMS directory and we couldnt find any error.



How could we fix this ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 03/12/2009 - 09:31

Is the LMS server integrated with ACS? It doesn't matter what account you use to login to the server, it only matters the account used to login to LMS. Is there one LMS username that works and one that does not?

CSCO11177789 Thu, 03/12/2009 - 14:59

No, we dont use ACS. Our LMS logon user is "admin" which we configure during installation. In domain or workgroup we use same username and password.

Marvin Rhoads Fri, 03/13/2009 - 06:10

One thing to look at - are both your local and domain accounts set up the same with respect to their browser security (java settings, etc.)?


If I understand correctly - you are accessing CiscoWorks locally (on the server) logging into the server OS using either:


a. a local (machine) account, or


b. a domain-based account from the AD domain which the server is a member of.


Then logging into CiscoWorks using its local, non-ACS-integrated, admin account.

CSCO11177789 Fri, 03/13/2009 - 07:05

We couldnt find any restriction on activeX or javascripts settings between local or domain account settings.


Yes,you are right. Only we use admin accoun t on LMS.


With domain-based account menus are disable but while using local machine account everything is ok.


Joe Clarke Fri, 03/13/2009 - 07:24

This does sound like an account environment issue. Can you try creating (or using) a new domain account to see if the problem follows the domain, or if it is local to this one domain account?

CSCO11177789 Fri, 03/13/2009 - 07:53

We've already tried enterprise admin account but still menus were disable.


last choice, we uninstall LMS and reinstall with domain acoount. But there must be a better and simple solution.



Marvin Rhoads Fri, 03/13/2009 - 08:12

Joe seems to be leaning towards my suspicion - an (OS) account-specific environment variable.


Some relevant Internet Explorer registry keys are in the HKCU\Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\ and HKCU\Software\Policies\Microsoft\Internet Explorer\Main\FeatureControl registry subtrees (among other places) that could affect your experience.


They are typically there as the result of application of the inetres.adm Group Policy Object (GPO), standard in Windows 2003/2008 server Active Directory environments. Note they are in the HKCU hive - Current User.


They can be modified via setting the options from IE's menus. I've typically added the local host to the "trusted sites" list to cover these arcane settings in one fell swoop.


Have you tried using a different browser?


CSCO11177789 Fri, 03/13/2009 - 10:52

LMS supports only IE6,7 and Firefox 2. So we tried IE6 and IE7 but, nothing was changed.


We configure internet option zone settings to low but still same.


Also we reinstalled Campus Manager 5.0.4 but it didnt work.


What do you suggest about your registry settings ?

Joe Clarke Fri, 03/13/2009 - 11:31

Please post the Java Web Start console output from the account where the links are disabled.

Joe Clarke Fri, 03/13/2009 - 13:58

Clear out the Java Web Start cache for this user from the Java Control Panel. Delete all of the temporary files. Restart the browser, and try again.

Joe Clarke Sat, 03/14/2009 - 11:10

What is the output of the DOS SET command from both the working and non-working accounts? What settings differ in the Java Control Panel between the working and non-working accounts? If you login as this domain account on another computer, does the problem still exist?

CSCO11177789 Sat, 03/14/2009 - 12:08

In java control panel, each settings are same for non-working and working accounts.

We send DOS SET command result for domain and local accounts.

We logon with same non-working account on another server in domain and we tested LMS from browser, still seeing disable.



Attachment: 
Joe Clarke Sat, 03/14/2009 - 12:23

You might try disabling anti-virus scanning, and see what effect that has. The files which generate these menu definitions are XML files found under NMSROOT/campus/www/classpath/com/cisco/nm/ani/clients/campus/sysmaps on the server. Something must be preventing them from being properly read under the domain account. Check with your domain administrator to see what security policies and other settings are pushed down to domain users. Find out what logon scripts run, and what they may do.

Actions

This Discussion