Cisco 877 pure bridge mode

Answered Question

I need to configure my Cisco877 just in bridge mode between ATM interface and interface VLAN1 so my PC would get public ISP IP address. I think this is done just setting my windows xp network interface for DHCP client. Could anyone send me or post this configuration file?

Thanks a lot!!!

Correct Answer by Giuseppe Larosa about 8 years 1 month ago

Hello Adis,

it should take an ip address by DHCP to give your PC a chance to telnet successfully.

You have ip routing disabled so the router can behave just as a PC.


Hope to help

Giuseppe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Fri, 03/13/2009 - 03:26
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Seba,

check what the ISP is giving you: if it is PPPoE you need a PPPoE client on your PC instead of DHCP


note: I've linked a document in the cisco web site



Hope to help

Giuseppe


Giuseppe Larosa Fri, 03/13/2009 - 03:56
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Seba,

>> No, it is not PPPoE o PPPoA.


then you need DHCP on the PC indeed


the configuration is fine because bridging doesn't care of upper layer protocols


Hope to help

Giuseppe



It works!

I tried this configuration this afternoon and it worked. I also defined DHCP client on my PC network card.

You can have a look at it:


Router#sh running-config

Building configuration...


Current configuration : 903 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

!

no aaa new-model

!

!

dot11 syslog

ip source-route

no ip routing

!

!

no ip cef

!

!

!

!

!

!

!

archive

log config

hidekeys

!

!

!

!

!

interface ATM0

no ip address

no ip route-cache

no atm ilmi-keepalive

pvc x/x

encapsulation x

!

dsl operating-mode x

bridge-group 1

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

no ip address

no ip route-cache

bridge-group 1

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

!

!

!

control-plane

!

bridge 1 protocol ieee

!

line con 0

no modem enable

line aux 0

line vty 0 4

login

!

scheduler max-task-time 5000

end


Router#



Thanks a lot for your help!


Adis

Giuseppe Larosa Sun, 03/15/2009 - 01:22
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Adis,

nice news it worked

be aware that in this way you have configured the router as a bridge and you can access it only via console.


Hope to help

Giuseppe


Correct Answer
Giuseppe Larosa Mon, 03/16/2009 - 08:15
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Adis,

it should take an ip address by DHCP to give your PC a chance to telnet successfully.

You have ip routing disabled so the router can behave just as a PC.


Hope to help

Giuseppe


Actions

This Discussion