vpnv4 connected routers not cummunicating

Answered Question
Mar 13th, 2009
User Badges:

I have 4 routers connected as per sketch below, I can ping my directly connected VRF's from both PE's(R2 can ping R1 and R3 can also ping R4). My PE's cannot ping each other.


both these PE's are running BGP 1000

then R4 BGP 65001 and R1 BGP 6500


(CE)R1 - R2(PE) -- (PE)R3 - R4(CE)


R2(PE)

!

interface Loopback0

ip address 4.4.4.4 255.255.255.255

!

interface ATM3/0.100 point-to-point

ip address 165.148.120.2 255.255.255.252

no atm enable-ilmi-trap

mpls label protocol ldp

mpls ip

pvc 1/100

encapsulation aal5snap

!

!

address-family vpnv4

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 send-community both

exit-address-family

!

!

R3(PE)

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

!

interface ATM1/0.100 point-to-point

ip address 165.148.120.1 255.255.255.252

mpls label protocol ldp

mpls ip

pvc 1/100

encapsulation aal5snap

!

!

address-family vpnv4

neighbor 4.4.4.4 activate

neighbor 4.4.4.4 send-community both

neighbor 4.4.4.4 next-hop-self

exit-address-family

!


I suspect the problem is with my MPLS cloud(vpnv4).

Correct Answer by Harold Ritter about 8 years 1 month ago

Lawrence,


When you say "PEs cannot ping each other", do you mean they can't ping each other directly connected interface address (atm1/0.100) or their respective loopback addresses?


Do you have a routing protocol running between the two PEs? If so, do see the neighbors loopback address?


Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Harold Ritter Fri, 03/13/2009 - 06:13
User Badges:
  • Cisco Employee,

Lawrence,


When you say "PEs cannot ping each other", do you mean they can't ping each other directly connected interface address (atm1/0.100) or their respective loopback addresses?


Do you have a routing protocol running between the two PEs? If so, do see the neighbors loopback address?


Regards

Actions

This Discussion