MPLS TE RSVP explicit problem

Unanswered Question
Mar 13th, 2009
User Badges:
  • Gold, 750 points or more

I have two routers connected in a lab via MPLS TE using RSVP. When i setup the tunnel to use explicit path-option

for example " tunnel mpls traffic-eng path-option 2 explicit identifier 2", the tunnel goes down and doesnt come up until i change it to use" tunnel mpls traffic-eng path-option 2 dynamic". Any ideas why this is not working?


R1


ip cef

mpls traffic-eng tunnels


interface Loopback0

ip address 150.1.1.1 255.255.255.255

!

interface Loopback1

description MPLS Traffic Eng

ip address 172.25.1.1 255.255.255.0


!

interface Tunnel0

ip unnumbered Loopback1

load-interval 30

tunnel destination 172.25.2.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 1 1

tunnel mpls traffic-eng bandwidth 100

tunnel mpls traffic-eng path-option 1 dynamic


interface Serial1/0

ip address 192.168.1.1 255.255.255.0

mpls traffic-eng tunnels

serial restart-delay 0

ip rsvp bandwidth 100


router ospf 1

mpls traffic-eng router-id Loopback1

mpls traffic-eng area 0

router-id 150.1.1.1

log-adjacency-changes

network 150.1.1.1 0.0.0.0 area 0

network 172.25.1.0 0.0.0.255 area 0

network 172.25.80.1 0.0.0.0 area 0

network 192.168.1.0 0.0.0.255 area 0

network 192.168.2.0 0.0.0.255 area 0

!


R2


ip cef

mpls traffic-eng tunnels


interface Loopback0

ip address 150.2.2.2 255.255.255.255

!

interface Loopback1

description MPLS Traffic Eng

ip address 172.25.2.1 255.255.255.0


interface Tunnel0

ip unnumbered Loopback1

tunnel destination 172.25.1.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng autoroute announce

tunnel mpls traffic-eng priority 2 2

tunnel mpls traffic-eng bandwidth 200

tunnel mpls traffic-eng path-option 2 dynamic


interface Serial1/1

ip address 192.168.1.2 255.255.255.0

ip ospf priority 0

mpls traffic-eng tunnels

serial restart-delay 0

ip rsvp bandwidth 200


router ospf 1

mpls traffic-eng router-id Loopback1

mpls traffic-eng area 0

router-id 150.2.2.2

log-adjacency-changes

network 150.2.2.2 0.0.0.0 area 0

network 172.25.2.0 0.0.0.255 area 0

network 192.168.1.0 0.0.0.255 area 0


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Harold Ritter Fri, 03/13/2009 - 11:21
User Badges:
  • Cisco Employee,

Franco,


The most obvious reason would be that the explicit path you are using is wrong.


Could you please post the explicit path option and a "show mpls traffic-eng tu " when the tunnel fails to come up.


Regards



jon.harald.bovr... Fri, 03/13/2009 - 23:46
User Badges:

Hi

assuming this is what are tested:


interface Tunnel0

tunnel mpls traffic-eng path-option 1 dynamic

tunnel mpls traffic-eng path-option 2 explicit identifier 2


This configuration should correctly select the dynamic path. The path-option number could be called priority, with path-option 1 as 'best'

vijaykumarArumugam Thu, 04/02/2009 - 05:01
User Badges:

Hi,

Could you post the "show ip explicit-paths" output. I couldn't locate the explicit path identifier 2 config from your running-config. May be you missed to configure the explicit path?


Sample config for R1:

Router(config)#ip explicit-path identifier 2

Router(cfg-ip-expl-path)#next-address 192.168.1.2

Explicit Path identifier 2:

1: next-address 192.168.1.2

Router(cfg-ip-expl-path)#do show ip exp

PATH 2 (strict source route, path complete, generation 3)

1: next-address 192.168.1.2

Router(cfg-ip-expl-path)#



Thanks,

Vijay

Actions

This Discussion