MWI not functioning after upgrade

Unanswered Question

Recently we upgraded IOS 12.4(20) T2 and CCUE ver 3.2 and our Message waiting indicators have stop functioning.  The light on the phone and as well as the message envelope does not display.  I went through

troubleshooting Unity Express Message Waiting Indication (MWI)  problems

and this was not much help.  Anyway Please assist this is causing big problems in the office!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Steven DiStefano Sun, 03/15/2009 - 18:57

a better community for support = www.cisco.com/go/smallbizsupport, or if this is broken after upgrade, maybe TAC..

Where you using button overlays when it was working before the upgrade?  I ask because i did hear of a case where the overlay was causing the CME to not recognize the DN when the MWI call would come from CUE and needed to be rebuilt....

It shouldnt be the case but make sure the IP address of CUE didnt change (debug ccsip messages)

there is also a cli command in CUEcalled 'mwi refresh all' may be worth a try...

http://www.cisco.com/en/US/docs/voice_ip_comm/unity_exp/rel3_2/administr...

I had checked that the CUE Ip was still the same, and as well as used the MWI refresh CLI when the problem firts began.   We were not getting email notifications at that time either, and then when i did the MWI refresh email notifications started coming in. The Email notifications is what make this situation tolerable.  I haven't had time to put a call in with TAC, but that definitely is my nest step.  If you have anyother suggestions im definitely appreciative.  Thank You

Moderator Tue, 04/07/2009 - 06:48

Hello,

Were you able to get in touch with TAC to reach a solution?

Thanks,

Cisco Moderation Team

Eivind Jonassen Tue, 04/07/2009 - 08:33

I´ve also had this problem. Have you checked the CUE sip gateway?? Log into CUE via CLI and do a sh run. There is a parameter in the config called SIP GATEWAY, this was wrong in my config eventhough I hadn´t changed anything. Put this back to 10.1.1.1, this worked for me anyways. Also take a look at the same issue from uc500.com @ http://www.uc500.com/mwi-not-functioning

Regards

Eivind

Yes i did put a call in with TAC and we went back and forth for about two weeks.  Ultimatley after running a traces on a call we noticed that after the call would go to voice the mail, it would then send a command to the MWI trigger which is A800 for on, and A801 for off.  Anyhow the triggers were saying it was busy, so we looked up the ephone-dn that was associated with the trigger and then deleted them, and the reconfigured the ephone-dn to associate with proper trigger.  This then brought the MWI functionallity back to our phone system.  Thank You everyone for you post and suggestions, this was such a finicky issue.

I might be wrong about stating the A800 or A801 is a trigger for MWI, but im pretty sure thats what he explained to me.  Anyway hope maybe this can help others.

jorgediaz77 Wed, 05/13/2009 - 09:13

I have tried all the fixes listed here. I tried removing the ephone-dn's and re-adding them. My SIP gateway was incorrect, I changed this and now one single phone can get the notification icon and light. However, none of my other phones. I tried to do the MWI refresh as well which didn't work. Restarted the phones with no change as well. Anyone have any alternate solutions or suggestions?

What I had to do is recreate the ephone-dn for the triggers A800 and A801, each one of these triggers is associated with an ephone-dn.  "MWI on" for us a A800 and "off" is A801.  The config looks like this do a "sho run" and find the ephone associated with your triggers.

ephone-dn  55
number A801...
mwi off
!
!
ephone-dn  56
number A800...
mwi on

So what we had to do is do a "no ephone-dn 55"

then configure the ephone back again with the same configs as above.  We had to do this to both and this restored are MWI.  To be able to edit the ephone-dn is

config t

telephony-service

no ephone-dn #

ephone-dn #

number A801

mwi off

Then do this for both ephone -dn.  Just make sure before you remove the ephone-dn that you have the prior configs to restore it back. Hope this helps this was suggested from TAC.

jorgediaz77 Wed, 05/13/2009 - 11:20

We managed to resolve the problem through a few steps on the CME. We had already removed and re-added the ephone-dn's but thanks for the suggestion.

Steven DiStefano Thu, 06/11/2009 - 06:53

Just wanted to add that I recently resolved a similar MWI not working issue as follows.

I enabled Terminal Monitor and 'debug ccsip messages' on the uc520 and traced the call, in particular, I wanted to see what CUE sents to the phone after the calling party deposits a voice mail.  I used extension 201 as the voice mail receipient in this test.  So you can skip the initial invite dialogs from setting up and seeing the call forward to voice mail.  As soon as you deposit the message and hang up, you should see an INVITE from your CUE (either your voice mail extension or your AA extension) to the MWI ON notification number, which using the above thread (repeating below) was A800...:

ephone-dn  55
number A801...
mwi off
!
!
ephone-dn  56
number A800...
mwi on

In the working case you should see TO:A800201 in the SIP INVITE header and MWI should go on the phone 201.

However, what I saw was TO:800201 and it received a SIP 404 (not found).  And my ephone-dn was the same as above.  SO this meant that the CUE setting for the MWI on and off were set to 800... and 801... (missing the A) since it is initiating the call.  There were two ways to fix this.  Easiesnt was to adjust the ephone-dn to number 800... and 801... (remove the A there too), but be advised that this then can interfere with your dialing plan if using 8.......

The correct way to fix this is to adjust in CUE itself.

Hope this helps.

Steve DiStefano

SE, US Field Channel Sales

Marcos Hernandez Thu, 06/11/2009 - 09:13

The commands in CUE can be found under the MWI application:

ccn application ciscomwiapplication aa
description "ciscomwiapplication"
enabled
maxsessions 6
script "setmwi.aef"
parameter "CallControlGroupID" "0"
parameter "strMWI_OFF_DN" "A801"
parameter "strMWI_ON_DN" "A800"

end application

Modify those to match your on/off ephone-dn.

Thanks,


Marcos

Brikers12 Wed, 06/17/2009 - 03:27

how can I output the current ciscomwiapplication config through the CLI? To see if my "strMWI_OFF_DN" might be set incorrect.

Marcos Hernandez Wed, 06/17/2009 - 08:06

You need to log into the Voicemail module (CUE):

UC500#service-module integrated-Service-Engine 0/0 session

Thanks,


Marcos

MWI Stopped working recently on a UC520. I ran a MWI refresh all from cli and GUI and still not working. I checked the SIP gateway which is set to 10.1.1.1 and I also checked the ephone-dn for MWI 800.... and 801.... both have the correct four dots as we are using 4 digit extensions. How else should I troubleshoot this issue.

Thanks.

Steven Smith Sun, 01/03/2010 - 12:21

It would be best to post the CME and CUE config to see where the error is.

prestonstrait Wed, 02/13/2013 - 12:47

I realize this is a pretty old post but it is the one I came across when troubleshooting a recent upgrade.  For me I had to add the CUE IP to the ACL specified here:

!

voice source-group CCA_SIP_SOURCE_GROUP_EXTERNAL

access-list 3

!

fritz.freund Thu, 02/28/2013 - 14:20

I had this same issue for a long time.. ended up being as simple as 3 dots.

when configuring the number for ephone-dn, don't forget to add the trailing dots. Our extensions are 3 numbers, so for us we added 3 dots at the end like this:

!

ephone-dn 30

number A801...

mwi off

!

DON'T FORGET THE DOTS!

Actions

This Discussion