Why EIGRP is not learning all the routes?

Unanswered Question

Two routes have EIGRP neighbor established over GRE interface but they are not learning the full routes in its neighbor's table.

Here are the config and show:

<old-denhav1012>

!

router eigrp 113

redistribute connected route-map deny_connected

network 10.116.129.2 0.0.0.0

network 10.175.211.252 0.0.0.3

distribute-list EIGRP-Tunnel-Out out Tunnel0

no auto-summary

eigrp log-neighbor-changes

!

old-denhav1012#sh ip eig nei

IP-EIGRP neighbors for process 113

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

0 10.175.211.254 Tu0 14 01:02:19 91 5000 0 410

old-denhav1012#

old-denhav1012#sh ip eig top

IP-EIGRP Topology Table for AS(113)/ID(192.168.207.35)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status

P 192.168.207.35/32, 1 successors, FD is 297372416

via 10.175.211.254 (297372416/128256), Tunnel0

P 10.175.211.252/30, 1 successors, FD is 297244416

via Connected, Tunnel0

P 10.116.40.128/28, 1 successors, FD is 28160

via Rconnected (28160/0)

P 10.116.129.2/32, 1 successors, FD is 128256

via Connected, Loopback10

old-denhav1012#

<denhav1012>

!

router eigrp 113

passive-interface default

no passive-interface Serial2/0:23

no passive-interface Tunnel0

network 10.175.211.252 0.0.0.3

network 192.168.207.35 0.0.0.0

no auto-summary

no eigrp log-neighbor-changes

!

denhav1012#sh ip eig 113 nei

IP-EIGRP neighbors for process 113

H Address Interface Hold Uptime SRTT RTO Q Seq

(sec) (ms) Cnt Num

0 10.175.211.253 Tu0 10 01:06:05 22 5000 0 12624428

1 10.116.64.219 Se2/0:23 14 04:06:28 222 2280 0 151500

denhav1012#

denhav1012#sh ip eigrp 113 top

IP-EIGRP Topology Table for AS(113)/ID(192.168.207.35)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status

P 0.0.0.0/0, 1 successors, FD is 30720, tag is 65309

via Redistributed (30720/0)

P 192.168.207.35/32, 1 successors, FD is 128256

via Connected, Loopback0

P 10.175.211.252/30, 1 successors, FD is 297244416

via Connected, Tunnel0

P 10.116.64.219/32, 0 successors, FD is Inaccessible

via 10.116.64.219 (41356800/128256), Serial2/0:23

denhav1012#

old-denhav1012 only learns one route from denhav1012 but not 0/0 nor 10.116.64.219/32?

Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Sun, 03/15/2009 - 05:33

Hello Frank,

10.116.64.219/32 is declared inaccesible and has an infinite metric = max metric.

P 10.116.64.219/32, 0 successors, FD is >> Inaccessible

via 10.116.64.219 (41356800/128256), Serial2/0:23

So this is correct I don't know why it is Inaccessible but for this reason it is not advetised to other router or if it is the route cannot be used

I think the reason can be that a better protocol like eBGP (AD 20) is providing a better route or that you need a network comand for it like:

network 10.116.64.219 0.0.0.0

for the default route you may need a redistribute bgp or static or the usage of the command

ip default network.

There are not enough details to undestand how new router learned the default route

Hope to help

Giuseppe

Giuseppe,

Thanks for the reply, it works after I added the network statement for 10.116.64.219, but I need to use a wilder mask to cover few more sites.

However still don't know why it was "Inaccessible", the prefix is not from any other routing protocol, the only thing it that they are all from ISDN circuits.

The default route was redistributed from BGP into EIGRP on denhav1012, it should send to its neighbor old-denhav1012 but why it doesn't.

If I add "ip default network" then defeats the propose using dynamic routing protocol.

Giuseppe Larosa Tue, 03/17/2009 - 07:25

Hello Frank,

router eigrp xx

no auto-summary

you can create a summary route on an interface basis (outbound) using

int type x/y

ip summary-address eigrp xx 10.116.64.0 255.255.255.0

this is an example

about the default route it is a special network and EIGRP has no direct way to indicate 0.0.0.0/0 (it can use some special flags on the network object of default network command)

I'm afraid it is not enough to use redistribute BGP for the default route

may you post the configuration ?

Hope to help

Giuseppe

Actions

This Discussion