SSH Connection Problems

Unanswered Question
Mar 16th, 2009
User Badges:

Could use some help here. I have an older version of Cirrus Config Manager that I used to upload config changes. It logs in to systems using SSH. Occasionally after it logs in though, something happens and I can no longer connect using SSH to that device unless I reboot it (telnet still works). Using putty, I get a message saying that the "Server unexpectedly closed network connection". After a reboot, I can get into the router (this seems like it is only happens on routers, and not switches). I know I have read that this happens if you change the hostname of the device, but the host name hasn't changed when this happens. I have tried to delete and regenerate the RSA key, but still no luck.


Thanks,


Troy

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Mon, 03/16/2009 - 04:14
User Badges:
  • Purple, 4500 points or more

It can also happen if you have to replace the device and or supervisor as the new key will not match the stored key in the device you are ssh'ing from, I have seen this going from a unix device and you have to clear the key for that device and make a new one . Also make sure you have your exec-timeout parameters set on the vty sessions.

Actions

This Discussion