Cisco Unified Presence and Cisco CCX Integration.

Unanswered Question
Ryan LaFountain Wed, 03/10/2010 - 13:47
User Badges:
  • Cisco Employee,

Hi,


The easiest thing to do is get CUPC working with the agent's credentials. Once that is working, you know that the CUPS piece is right. The document supplied previously shows the very limited CAD configuration that is required. This should go fine once you get CUPC working with the agent's information.


Keep in mind that CUPC is not the same as CAD and there are important differences:


1. You need to add an Inbound ACL to the CUPS server to allow connections from the CAD PCs as CAD does not support Message Digest as CUPC does. This is CSCtb50109.


2. CAD does not escape special characters in the password, so use a password without special characters. This is /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} CSCtf25959.

Anthony Holloway Wed, 03/10/2010 - 17:59
User Badges:
  • Purple, 4500 points or more

I was running 7.0(1) SR1, and my TAC engineer had me stop using DNS, and use the hosts file.  I could resolve the name with DNS, so I didn't understand his tactics, but sure enough, it started working.  So Ryan, is this something you've heard of?


Message was edited by: Anthony Holloway - To clarify, I am referring to the UCCX server, not an Agent PC.

Tony Knight Wed, 03/10/2010 - 19:02
User Badges:

Thanks for that, it worked first time (without the DNS issue).


Cheers

Anthony Holloway Wed, 03/10/2010 - 22:13
User Badges:
  • Purple, 4500 points or more

Are you saying that you too stopped using DNS, and now it works?

Anthony Holloway Thu, 03/11/2010 - 14:37
User Badges:
  • Purple, 4500 points or more

Oh I see.  You replied to my post with "thanks", but now I think you meant to reply to Ryan's post.  So you did what Ryan suggested and it now works?

Actions

This Discussion