3750 MPLS ring Jumbo MTU problem

Unanswered Question
Mar 16th, 2009
User Badges:

Hi all, I wanted to run this by someone to see if they had an easy answer. We fixed the problem but we'd like to know why it was an issue.


The ring in questions is a 8 node MPLS ring using 3750MEs. There is a head-end switch where clients around the ring would get internet from.


I replaced the head-end switch last week and in doing so, forgot to set the Jumbo mtu setting to match the rest of the switches around the ring. All other switches were set for 1546 while the head-end switch was set for 1504. Customer called in complaining that they couldn't hit certain websites, vpn's weren't working, etc...


Once we set the switches MTU setting to match that of the other switches in the ring, the issues cleared up.


Does anyone know why a jumbo mtu setting mismatch would effect web and vpn traffic? Is just having a mismatch enough to confuse it? It wouldn't seem that web or vpn traffic would pass as a jumbo frame.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 03/16/2009 - 07:53
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Andrew,

C3750 ME have ip mpls enabled by default.

So an additional 4byte mpls header can play a role here.

So in accessing web sites and in trying to get 1500 bytes packet sent to other switches one could have to take in account

1500 byte IP packet

4 byte MPLS header

4 byte 802.1Q header


This is only a guess but this can explain your problem


Hope to help

Giuseppe


Actions

This Discussion