FXO on an H.323 GW to FXS on MGCP GW: FAX not working

Unanswered Question
Mar 16th, 2009
User Badges:

I have an FXO port for a 1MB line on an H.323 gateway which forwards calls to a CUCM 6.0 server.


FXO Config:


voice-port 0/2/0

echo-cancel coverage 64

timing hookflash-out 50

connection plar 4488

description LINE FIVE

caller-id enable


Dial-peer config:


dial-peer voice 1000 voip

description TO-CUCM

destination-pattern ....

session target ipv4:10.2.0.1

dtmf-relay h245-alphanumeric

no vad


FXS Config:


voice-port 0/3/0

echo-cancel coverage 64


FXS Dial-peer config:


dial-peer voice 999230 pots

service mgcpapp

port 0/3/0


A fax machine is plugged into the FXS port. When the 1MB line is called, it will ring about 4 times and then you get about half a second of the fax beep and then then there is no more audio, though the call is not dropped and the faxes do not go through.


The FXS is registered correctly on the CUCM server. Other inbound calls work via 1MB lines on this router but this is the only one going to an FXS port.





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Mon, 03/16/2009 - 21:17
User Badges:
  • Red, 2250 points or more

Try:

mgcp modem passthrough voip codec g711u

mgcp fax t38 inhibit (default)

no mgcp fax-relay sg3-to-g3

no mgcp fax-relay ans-disable


voice-p 0/3/0

input gain -5

output attenuation 5


On the H323 side:


voice service voip

modem passthrough nse codec g711ulaw




hth,

nick


Actions

This Discussion