Problem with telnet from outside to inside (Router1841)

Answered Question
Mar 16th, 2009

Dear All Expert,

Right now, i had problem with telnet from outside to inside,but i can telnet from inside to router.i don't know what is issue. Please see in the attach file.

Attachment: 
I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 7 years 8 months ago

Configure:

no access-list 1

access-list 1 permit 192.168.1.1 0.0.0.31

And will be working fine. Remember: never use "any" for NAT ACL.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rupesh Kashyap Mon, 03/16/2009 - 21:29

hi, I am not finding any configuration problem. Do one thing, enable debug ip packet on outside interface and see the telnet traffic.

rechard_david Mon, 03/16/2009 - 21:42

Dear Rupesh,

Thanks you for your help ...

Could you let me know the command enable debug to see telnet .....?

best Regards,

Rupesh Kashyap Mon, 03/16/2009 - 21:49

1. debug ip packet

You can do one think.

Line vty 0 4

access-class 2 in

access-list 2 permit tcp any any eq 23 log

rechard_david Tue, 03/17/2009 - 20:39

Dear Rupesh,

thanks for your help!!!

this command i tried to used but it still cannot telnet from outside. Oh!! how can we know ISP block ? last time i asked ISP guy and they said no block any thing.... and they don't have firewall ... so how can we make sure our router is ok and ISP has problem.......

Could you advice me how can i do and solve this issue.?

Best Regard

Correct Answer
Paolo Bevilacqua Tue, 03/17/2009 - 20:57

Configure:

no access-list 1

access-list 1 permit 192.168.1.1 0.0.0.31

And will be working fine. Remember: never use "any" for NAT ACL.

Rupesh Kashyap Tue, 03/17/2009 - 22:44

At first, You have to check, Telnet traffic is reaching to ur Outside interface or not, if initiated from Outside world. Do Debug is the best command to check the Telnet packet. If traffic is not received, then check with ur ISP.

1. Debug ip packet

2. Debug ip packet Detail

3. Debug ip packet interface 2 ( if ACL 2 is applied)

thiru.vel10 Tue, 03/17/2009 - 22:49

Hi ,

Please remove the “ip nat outside “ from WAN interface and then try to telnet from outside.

Actions

This Discussion