Redistributing vs. advertising

Unanswered Question
Mar 17th, 2009

I've read a lot of Cisco documentation and have worked through the relevant sections of Jeff Doyle's book, but I'm still having difficulty with this topic. Can somebody give a "25 words or less" sort of explanation of the difference between "redistributing via" and "advertised by"?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 03/17/2009 - 07:18

Hello George,

if you don't see the line advertised by the route is not actually propagated in the destination routing protocol

example from our network

sh ip route 10.34.22.144

Routing entry for 10.34.22.144/28

Known via "static", distance 1, metric 0 (connected)

Redistributing via isis

Advertised by isis metric-type internal level-1-2 route-map red_stat

Routing Descriptor Blocks:

* directly connected, via Tunnel49

Route metric is 0, traffic share count is 1

redistributing via IS-IS means there is a redistribute static inside IS-IS process

the line advertised by means that is really advertised

Hope to help

Giuseppe

Edison Ortiz Tue, 03/17/2009 - 07:21

You will only see those 2 entries on a route when the router is running 2 or more routing protocols.

If you see the entry redistributing via, it means that route is running within that routing protocol and it's eligible for redistribution into another routing protocol.

If you see the line above along with advertised by, it means the route has be redistributed and it's currently being advertised. It will also show the routing protocols where this route exists.

HTH,

__

Edison.

Giuseppe Larosa Tue, 03/17/2009 - 07:30

Hello Edison,

I confirm the following is a subnet of another building in the same campus

sh ip route 10.103.70.0

Routing entry for 10.103.70.0/24

Known via "isis", distance 115, metric 30, type level-1

Redistributing via isis

Last update from 10.82.130.149 on TenGigabitEthernet3/6, 7w0d ago

Routing Descriptor Blocks:

* 10.82.130.149, from 10.80.0.116, via TenGigabitEthernet3/6

Route metric is 30, traffic share count is 1

Thanks for your correction I was thinking only of the case when you want to check if a redistributed route is really advertised in the destination protocol

Best Regards

Giuseppe

Edison Ortiz Tue, 03/17/2009 - 07:34

Giuseppe,

No problem :)

The OP question is one of those tricky question I've seen on interviews and the naming used on the output is quite misleading.

__

Edison.

adamclarkuk_2 Tue, 03/17/2009 - 07:22

[Edit]

Misread the question

Redistributing is injecting a route/prefix from another source be it from a static route or another protocol, advertising a route is originating that route from the protocol itself. It is always better to source than to redistribute if possible.

Example

BGP

I have a static route on my router pointing to Null 0

ip route 192.168.1.1 255.255.255.255 Null/0

I can pass this into the BGP RIB via 2 methods, redistribution or originating the route

redistro

router bgp 65535

redistribute static subnets

Originate

router bgp

network 192.168.1.1 mask 255.255.255.255

Edison Ortiz Tue, 03/17/2009 - 07:40

Adam,

Redistributing is injecting a route/prefix from another source be it from a static route or another protocol, advertising a route is originating that route from the protocol itself. It is always better to source than to redistribute if possible.

That's not the answer on this scenario :)

lamav Tue, 03/17/2009 - 07:26

Give me the relevant pages from the DOyle book, please, so I can read it for myself.

Thanks

gkuzmowycz Tue, 03/17/2009 - 08:11

Thanks to all for replying. Didn't know I'd spark such a discussion.

To Edison: this isn't/wasn't from an interview, I'm just trying to understand. As you noted, the output from sh ip route isn't as clear as I'd like.

To Adam: I know what redistribution is -- this was a bit more involved, as I'll show below.

To Victor: Jeff Doyle's Vol 1 Chapter 11 (page 694 ff) is about redistribution, but my reason for posting here was that it didn't actually answer the distinction.

What I have, edited for brevity, is this

router eigrp 1

redistribute connected

network 172.16.205.0 0.0.0.255

network 172.16.206.0 0.0.0.255

network 172.18.0.0

no auto-summary

!

router bgp 65000

bgp log-neighbor-changes

neighbor nn.nn.nn.nn remote-as xxx

!

address-family ipv4

redistribute eigrp 1

neighbor nn.nn.nn.nn activate

no auto-summary

no synchronization

which gives me an actual view like this

VG3-3845#sh ip route 172.28.0.0

Routing entry for 172.28.0.0/16

Known via "eigrp 1", distance 120, metric 178944, type internal

Redistributing via eigrp 1, bgp 65000

Advertised by bgp 65000

Last update from 172.16.205.1 on GigabitEthernet0/0, 3w2d ago

Note that 172.28.0.0/16 is not "originated by" either routing process and is not directly connected. It is learned via EIGRP from one of this router's neighbors. That fact, to me, explains why it is "redistributed via" the EIGRP 1 process. The "redistribute eigrp" in the BGP process explains why it is "redistributed via" the BGP 65000 process. What I was trying to understand was why it is only "advertised by" the BGP process and not by the EIGRP process.

Edison Ortiz Tue, 03/17/2009 - 08:21

George,

I didn't mean to imply you saw the question on an interview. I said "I've seen that question in some interviews" :)

BTW, I re-read my previous reply and the redistributing via will list the routing protocols that are currently advertising the route, NOT the advertised by entry.

The naming convention used is quite confusing and every time I think about it, I have to think backwards.

Here is a native EIGRP route that is being redistributed into OSPF.

R2#sh ip route 32.0.0.0

Routing entry for 32.0.0.0/8

Known via "eigrp 1", distance 90, metric 156160, type internal

Redistributing via ospf 1, eigrp 1

Advertised by ospf 1 subnets

Notice the router is telling us that the route is on both databases with the redistributing via but the router is only advertising the route as OSPF route since it received this route as EIGRP from a neighbor.

In your case 172.28.0.0/16 was learned via EIGRP. The route is on both EIGRP and BGP and it's currently advertising it via BGP.

__

Edison.

gkuzmowycz Tue, 03/17/2009 - 09:12

Edison:

I really do appreciate your responses, but I guess I'm still not understanding. Maybe I'm just dense. But "advertising by" doesn't make much sense to me. Going back to my config, for instance, the only router which has 172.28.0.0/16 as a connected interface has the following config

router eigrp 1

network 172.28.0.0

network 172.29.0.0

auto-summary

!

router rip

network 172.28.0.0

network 172.29.0.0

Yet it shows me this

R2#sh ip route 172.28.0.0

Routing entry for 172.28.0.0/16

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via eigrp 1, rip

Advertised by rip

What information is "Advertised by rip" giving me? It's a directly connected network, and it's being "originated", as far as I understand, by both routing processes.

Edison Ortiz Tue, 03/17/2009 - 09:24

George,

Here is what I get when having the same route on both networks introduced into that routing protocol via the network command:

R2#sh ip route 22.2.2.2

Routing entry for 22.2.2.0/24

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via ospf 1, eigrp 1

Routing Descriptor Blocks:

* directly connected, via Loopback2

Route metric is 0, traffic share count is 1

Now, this is what I get when introduced into that routing protocol via redistribution:

R2#sh ip route 23.3.3.3

Routing entry for 23.3.3.0/24

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via ospf 1, eigrp 1

Advertised by ospf 1 subnets route-map CONNECTED-TO-IGP

eigrp 1 metric 1 1 1 1 1 route-map CONNECTED-TO-IGP

Routing Descriptor Blocks:

* directly connected, via Loopback3

Route metric is 0, traffic share count is 1

Now, you have come to a corner case scenario. In your case, 172.28.0.0/16 is on both EIGRP and RIP databases but EIGRP has a lower AD so it treats EIGRP as the primary routing protocol and RIP as the secondary routing protocol and they are both using the same link/neighbor, so in essence, you are bringing an EIGRP route into RIP and advertising it by RIP.

What are your neighbors, RIP or OSPF?

gkuzmowycz Thu, 03/19/2009 - 13:04

Sorry, I didn't see the question in your last line. This router's neighbor (it has only one) is running both EIGRP and RIP. No OSPF.

Things have gotten murkier, though. I have removed the RIP process from the router in question by removing all the network statements from "router rip" and then saying "no router rip". If I say sh ip route rip or sh ip rip database I get nothing. Yet there's this

R2#sh ip route 172.28.0.0

Routing entry for 172.28.0.0/16

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via eigrp 1

Advertised by rip

Routing Descriptor Blocks:

* directly connected, via TokenRing1/0

Route metric is 0, traffic share count is 1

So I'm "advertising by" a routing protocol that this router is not running. This is not helping me understand.

gkuzmowycz Fri, 03/20/2009 - 08:25

How long did you wait?

It had been over 24 hours.

Try clearing the route table.

That fixed it. Thanks.

milan.kulik Fri, 03/20/2009 - 04:02

Hi Edison,

IMHO, the explanantion might be:

The "Advertising by" line is showing the particular command used for the redistribution from one routing protocol to the other.

I.e., in your case, you probably use:

router ospf 1

redistribute eigrp 1 metric 1 1 1 1 1 route-map CONNECTED-TO-IGP

and

router eigrp 1

redistribute ospf 1 subnets route-map CONNECTED-TO-IGP

aren't you?

I can't explain the previous example:

"R2#sh ip route 172.28.0.0

Routing entry for 172.28.0.0/16

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via eigrp 1, rip

Advertised by rip"

It looks like a RIP route redistributed into EIGRP by "redistribute rip" command.

I can't remember: isn't there RIP redistribution to EIGRP automatic in IOS?

BR,

Milan

Edison Ortiz Fri, 03/20/2009 - 07:41

I.e., in your case, you probably use:

router ospf 1

redistribute eigrp 1 metric 1 1 1 1 1 route-map CONNECTED-TO-IGP

and

router eigrp 1

redistribute ospf 1 subnets route-map CONNECTED-TO-IGP

aren't you?

Yes.

I can't remember: isn't there RIP redistribution to EIGRP automatic in IOS?

No.

__

Edison

Actions

This Discussion