WAAS and Samba 2.2.7

Unanswered Question

Need some help. When the default CIFS application policy is set to "full optimize" for port 139 and 445, our users connecting to AIX servers that are running Samba 2.2.7 start seeing extremely poor performance. Files take minutes to open, or files don't show up in folders. When putting the application policy in a pass-through mode, users using the samaba share go back to normal. Has anyone seen this? We are running 4.1.1c

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
dstolt Tue, 03/17/2009 - 18:38


I do not see Samba support documented other then "RedHat Samba" in the Config guide. I can't find where 2.x was tested or planned to be officially supported.

I would recommend that you create a customer classifier and put your AIX server's IP address as the destination IP (and maybe put the ports as 139/445 if you do other functions on this box) and set the classifier to full optimization (No CIFS AO optimization). That way you should still get TCP Optimization and compression (DRE+LZ) on the traffic, however the CIFS AO (or legacy CIFS apdapters) won't interfer with the CIFS dialect the older version of Samba is using.

Let me know if that works for you,


dstolt Thu, 03/19/2009 - 07:16

Thanks for letting me know. Please update the forum with your results.


We put the default CIFS policy back to full optimize with CIFSAO. The problem has not re-appeared. The work-around was not applied. Toggling the policy off and on basically fixed it. We know the policy is what was causing the problem because the minute it was disabled, all of the user complaints were resolved immediately.

Thanks for the help.

dstolt Tue, 03/24/2009 - 21:01

Glad to hear it, thanks for letting me know.



This Discussion