Problems after upgrade to 7.1.0

Answered Question
Mar 17th, 2009

Everything installed perfectly but when I attempt to login via the web, it gives me the "System is not initialized. Only Administrator logins are allowed". When I run the Initialization Wizard and click next (to accept the CME login information, it gives me this: "Login to CallManager Express as Administrator failed. Check your CallManager Express configuration."

I've read a few other posts regarding making sure the "ip http path flash:/gui" is entered correctly - it is. This doesn't appear to be a GUI issue but more of an authentication one. Has anyone else seen this? Thank you.



Correct Answer by Marcos Hernandez about 7 years 11 months ago

Just for kicks, can you try in uppercase?

ip http path flash:/GUI

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (2 ratings)
Loading.
David Harper Tue, 03/17/2009 - 16:25

This sounds like a system that has not yet been configured at all.  When you connect to the web GUI, you are being prompted to log in with the default credentials (cisco/cisco) and perform the initial configuration of the VM/AA application.  I would suggest using CCA to perform the initial configuration of the system now that you have upgraded it.  Once that has been done, you will be able to log on to the GUI normally.

Cheers,

Dave.

knakatsu Tue, 03/17/2009 - 19:05

Dave,

Thanks for the response.  You're right in that the web gui reports "System is not initialized. Only Administrator logins are allowed." however, I upgraded my existing configuration with the 7.1.0.  All my users, phones, extentions, etc. are there but I am unable get past the first of five initialization steps in the web gui as it keeps telling me that login to CME (with cisco/cisco) failed.  I loath Windows so have tried to avoid CCA up till now.  Is there any way I can fix/test this via CLI?  If not, I'll install CCA and try that.  Thanks again.

Kory

Marcos Hernandez Tue, 03/17/2009 - 19:33

Did you create a directory structure for your files? If so, the CME GUI files are now under a new directory and you will need this:

ip http path flash:/gui

Marcos

presgargary Wed, 02/23/2011 - 07:41

Hey Marcos, I received the same error after the upgrade and your hint worked.  Thanks

David Harper Tue, 03/17/2009 - 19:34

I understand.  There is no requirement to use CCA - it is just a bit simpler for a lot of things.

Typically when you perform a software upgrade that involves updating the VM/AA software, you need to backup the VM/AA configuration and database first and then restore after the upgrade.  If this was not done, then you will need to reconfigure the VM/AA application.  Log on here using the credentials cisco/cisco, and the installation wizard should walk you through the process of setting everything up.

Cheers,

Dave.

knakatsu Tue, 03/17/2009 - 21:59

Dave/Marcos,

Thanks for your responses.  The "ip http path flash:/gui" is in the config.  My problem is this, the VM/AA is all fine after the upgrade.  I installed CCA 1.9 and it saw my configs (CME and CUE) perfectly.  The problem is somewhere with the web GUI.  When I access via the web, here is exactly what happens:

1. Login Screen: cisco/cisco - works!

2. Initialization screen: If I choose initialize it takes me to the first of 5 steps which is CME and XML credentials.  I enter cisco and cisco for the web and leave the XML stuff blank.  When I hit "next", I get an error that says "Login to Callmanager Express as Administrator failed.  Check your Callmanager Express Configuration"

3. If I choose "Skip Initialization" from the Initialization screen, it takes me in to the main screen and I can access anything related to CUE but nothing CME related.  For example, I can configure voicemail boxes, AA, etc. but if I choose "Configure/Extentions", I get a page that says "Error: Unable to login as administrator to the Cisco CallManagerExpress at site 'local'.  Details: CME login failed"  There is a Site Name selection but only "local" is available as a selection.

4. I can log in to CME via SSH and CCA all day long - it's just the web GUI that apparently can't authenticate.

The only reference I see in the configs to 'local' is:

[CME]

ip http authentication local

line vty 0 4

login local

transport input telnet ssh

transport output telnet ssh

line vty 5 100

login local

transport input telnet ssh

transport output telnet ssh

[CUE]

site name local

site-hostname 10.1.10.2

web credentials hidden "GixGRq8cUmFqrOHVxftjAknfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmPSd8ZZNgd+Y9J3xlk2B35j0nfGWTYHfmP"

end site

I have manually re-entered the web credentials in the CUE config to specify cisco/cisco and it still doesn't work.  It seems that the problem is with the web application itself.  Let me know what else I can provide to help solve this.









Thanks again for your help.

Kory

David Harper Tue, 03/17/2009 - 22:34

When you specified the CME credentials in the installation wizard, did you use the same credentials you use to telnet/ssh into CME?  Basically what the installation wizard is trying to do at that point is to connect into IOS and dump the CME configuration.  If it cannot get sufficient access to be able to dump the CME configuration, then the wizard will fail as you have described.

So, make sure the credentials you supply are for a privilege level 15 user, and you should be good.  Otherwise the VM/AA application will be running in complete ignorance of CME, and nothing will really work.

Cheers,

Dave.

Marcos Hernandez Wed, 03/18/2009 - 03:17

The command I suggested is only needed if you implemented the directory structure for this load and that CCA configures automatically. Can you provide a show flash too?

Thanks,

Marcos

knakatsu Wed, 03/18/2009 - 09:47

I can't believe it but that was it...  Thanks Marcos and Dave for all your help!

Kory

ihernandez81 Wed, 04/29/2009 - 05:55

Kory,

Thanks for posting! I just ran into the same problem! LOL, I changed the CMEGUI to cmegui and it started working! So don't fee bad...Have you noticed that the gui files can be stored in a folder, but if you try and put ringtones and phoneloads into a folder and then add them to your tftp server as a folder path, it doesnt work? just wanted to throw that out there. I had to put all my files on the flash root in order for it to work...

Anyway, thanks again.

Steven Smith Wed, 04/29/2009 - 07:33

You can put those files into folders as well.  When you do the tftp-server command, you also need to use the alias command.  It would be like...

tftp-server flash:/files/file.txt alias file.txt

Then you can put phone loads, RingList files and more into directories.  Also, when you use ringlist and desktops, the file location is actually stored in the xml file.  You have to make sure that everything is pointing to the correct location to do this, but it is definitely possible.

knakatsu Wed, 03/18/2009 - 09:18

Dave,

The only credentials I have on that box are cisco/cisco (level 15).  I use that to login via ssh but it doesn't work via the web for some reason.  Let me know if you need any additional information and I appreciate your help.

Kory

Actions

This Discussion