cant run a command after upgrade to 7.0.2

Unanswered Question
Mar 18th, 2009

Hi guys,

I have upgraded my UC520 to software pack UC520-7.0.2. The upgrade went all good but after configuring it via CCA1.9.1, I cant run the following commands.

voice service voip

supplementary-service sip refer

supplementary-service sip moved-temporarily

The commands seem to be exceuted but when I do show run then I cant see them in teh configuration. Can any one help me out to run these commands on the current software version. I was able to run on my previous version.

Thanks,

Yasin Nizami

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Wed, 03/18/2009 - 05:56

They are there, but because they are default settings you won't see them. This is typical IOS behavior. If you were to negate them, they would show up because now they are not default values.e

Hope this helps,

Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

yaqeel299 Wed, 03/18/2009 - 05:59

Marcos,

Thanks for your quick response. But UC20 is not doing REFER in transfering the calls. I had to turn on via these command on the previous version to make the transfer worked. I am using UC520 on a SIP trunk account. The ITSP follows the REFER method of transfer.

Thanks

Marcos Hernandez Wed, 03/18/2009 - 06:02

I see. What IOS version are you using? Can you capture a "debug ccsip message" for a test call?

Marcos

yaqeel299 Wed, 03/18/2009 - 06:11

Hi Marcos,

Please find the attached SIP trace for the attempted transfer call. It is not following the REFER method of transfer causing the calls to get disconnected. The IOS version is,

Cisco IOS Software, UC500 Software (UC500-ADVIPSERVICESK9-M), Version 12.4(20)T2, RELEASE SOFTWARE (fc4)

Thanks,

Yasin

yaqeel299 Wed, 03/18/2009 - 07:10

Hi Marcos,

I have sent you my config file on your email address. It was a blind trasfer. I cant do consultive trasfer either. It seems like an IOS issue?

Regards,

Yasin Nizami

Marcos Hernandez Wed, 03/18/2009 - 08:03

I found the following Software Defect:


CSCsu71853: SIP "Replaces" & "Referred-By" fields are not present on call transfers

This is supposed to be fixed in 12.4(20)T2, but I am still investigating.

Marcos

yaqeel299 Wed, 03/18/2009 - 08:08

Hi Marcos,

That application session command didnt help. The transfer is stiill failing. Its good that you pointed out the defect on the software. Is there any software version that I can install to fix that issue?

I have tried to run the "no" form of those commands and those ones stays in the config when i do show run.

Thanks,

Yasin Nizami

Marcos Hernandez Wed, 03/18/2009 - 09:26

You say this was working in a previous IOS? Please confirm the version.

Come to think about it, because this is an SCCP originated transfer (rather than SIP) I think sending the RE_INVITE is what we normally do.

Marcos

yaqeel299 Wed, 03/18/2009 - 09:47

Hi Marcos,

Unfortunately  I couldnt hold the record of the previous IOS version. The previous version with the whole pack was US localization related. Then I tried to upgrade the UC520 software pack with UK localization files and I ended up with this. I can confirm, in the previous version I had to turn on the REFER compatibility from the CLI to get the transfer work on SIP. Now it doesnt seems to attempt a REFER.

What I remember on the top of my head is the version was 12.4(11r). I cant remember the IOS file name. One more question, If I downgrade the IOS to 12.4(11x) then do I need to downgrade the CME and CUE too? or I just can replace the IOS? Please help.

Thanks

Yasin Nizami

yaqeel299 Thu, 03/19/2009 - 03:24

Hi Marcos,

Can you recommend a software pack that I can upgrade my UC500 to. I am really in need to get the transfer work. Please help.

Thanks

Yasin

Marcos Hernandez Thu, 03/19/2009 - 07:11

It is not clear to me which IOS you were running before, but I will assume it was in the 12.4(11)XW branch. I cannot find any reference of this ever being implemented as you suggest (when doing SCCP to SIP).

At this point my advice is that you open a TAC case. Send me the case number and we will monitor its progress and post the results on this thread.

Thanks,

Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

yaqeel299 Mon, 03/30/2009 - 04:53

Hi Marcos,

I have downgraded to 12.4(11W) and it is working now. This seems like a bug in the latest IOS release that doesnt support the supplemtary services commands. Anyway thanks for your help.

One quick question, can we present the CLIP as our own configured number when dialing out?

Thanks,

Yasin Nizami

Marcos Hernandez Mon, 03/30/2009 - 09:05

This is very strange. I have forwarded this issue to the colleague responsible for SIP trunk interop. I will post his comments once we determine what's going on here.

Thanks,

Marcos

Marcos Hernandez Mon, 03/30/2009 - 10:45

These are the comments from my colleague:

"To be honest, very few SPs support REFER so using the "no supplementary-service sip refer" is our strong recommendation. The big reason is CME will send REFER for all blind transfers regardless if the transfer is to an internal extension or to an external PSTN number. The problem is the SP now would get REFERs for internal extensions which it has no clue about and cause failures.

The only time CME sends a SIP REFER is:
- supplementary-service sip refer is enabled (default) AND
- call comes in on SIP Trunk to SCCP phone and SCCP phone does a BLIND transfer to another SCCP phone or back to PSTN

The best option is to have him open a TAC case and troubleshoot from there OR not use REFER as indicated earlier as it will not gain him a whole lot."

Thanks,

Marcos

Actions

This Discussion