CUCM6.1 CDR Reporting - "There are no matching records" error

Unanswered Question
Mar 18th, 2009

Hi all,

We moved away from CM 3.3 to a new installation running CUCM 6.1(2)

Although i have an account to review CDR records, each time i search for data between any given times, i get an error that there is no data.

I suspect that we do not currenty have CDR and/or CAR running properly on our cluster. Can anyone shed light on what *must* be set running to generate call detail records that i can review?

Enterprise Parameters:

CDR File Time Interval = 1

Service Parameters > Service > "Cisco CallManager"

CDR enabled flag = true (only set on Publisher our Subs are 'False')

Call Diagnostics Enabled = False

Clearly i may need to tweak some of these settings. However, can anyone categorically state what should be active, and whereto activate it(Pub/Sub and the relevant GUI location etc) to get CDR records working?

I get the feeling there may be one or more services that need to be started on the Publisher to collect CDR records....?

Many thanks

EDIT - checking the "CDR and CAR Reporting document" pdf from Cisco, would suggest that CDR records are activated simply by setting the System > Service Parameters (Cisco CallManager) "CDR Enabled Flag" to TRUE on all nodes in the cluster? Is that all i need to set to have the server start collecting CDR records?

I suspect i need to 'Activate' the Cisco CallManager service which appears to be inactive on the Publisher...

CDR Management shows we have 3GB set aside for files, which overwrite after 30 days.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
andy_vvc2 Thu, 03/19/2009 - 06:54

I have been advised that i will need to set the "CDR Enabled flag" = to TRUE on ALL nodes (inc Publisher)

The "Cisco callManager" service is NOT active on the Publisher though, and this setting is part of that service. Should this service be activated on the Publisher...?

Is it really only this flag that needs to be active on all nodes...?

andy_vvc2 Fri, 03/20/2009 - 04:19

I will be enabling the 'Cisco CallManager' service on the Publisher tonight.

I will also be stopping the CAR service on the Subs (Cisco state it should only run on the Pub?)

I will also be setting to 'TRUE' the "CDR Enabled flag" on all the nodes.

Does this sound like it will start CDR reports being generated, or might there be more i need to do?

andy_vvc2 Fri, 03/20/2009 - 14:52

Fixed ! :o)

Took a restart of the CAR services, then the CAR Sceduler, then the Database Layer Monitor on the subs then the publisher.

Actions

This Discussion