Router IOS Upgrade using USB Hard Drive

Unanswered Question
Mar 18th, 2009
User Badges:

Is there a particular brand and/or size USB hard drive that the 2800 series routers will recognize? In the past I have used a 1 to 2 GB USB stick and formatted as FAT. Most of these would be recognized. However, now we are not longer allowed to utilize the USB Tokes, but we can use a Serialized USB Drive to upgrade. I have tried a WD 250 GB drive and partioned it to 1GB (the rest is wasted). Even after formatting, the drive is no recognized by the router. As a side not, our IA team will not allow ANY USB Tokens, including the Aladdin line, to be used.


Any suggestions as to how to accomplish this or how to update the IOS without using USB Tokens or TFTP?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Collin Clark Wed, 03/18/2009 - 09:50
User Badges:
  • Purple, 4500 points or more

It sounds like you have the same security policy we do (we're also a sub for the DoD). We use FTP (still waiting for guidance if this OK), but our backup plan is to use SCP. Certainly slows things down, but it works. You could either run a central server or the other option we found was to use VanDykes VShell server on our workstations.


http://vandyke.com/products/vshell/index.html


As far as a USB drive, I have never tried to connect one to a router. I'll see if I can dig one up and try it in the lab.


Hope that helps.

gilson_gdit Wed, 03/18/2009 - 11:48
User Badges:

Thanks, I'll have to look into that. The only drawback is that the software is not approved for use on our networks. Since I posted this, I did purchase a Seagate FreeAgent 250GB drive. After partioning it to 2GB and formatting it to FAT (so the router will see it) I was able to copy to/from the router and drive. For our use this is prefreablt since the end user is not able to update the routers, it is only the techs. I'll update this once I finalize the testing.


As a side note, I was using a USB Jump drive before but with the DOD mandate against such Items and our IA overreaction, I almost had to go back to TFTP.


Thanks again.

Leo Laohoo Wed, 03/18/2009 - 14:53
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Won't work. The "maximum" allowed by is 2Gb. I tried plugging an 8Gb USB and it sure took a looooooooooooooong (I'm-going-to-make-some-coffee long) time before it was recognized. Once it's recognize, from the router, do the "format usb0:" command and it should work.


Have you tried using some of the new Solid State Drives? Samsung, Transcend, SanDisk and more have internal SSD available.

Leo Laohoo Wed, 03/18/2009 - 14:55
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

... I still don't get it. USB flash drives are not allowed but portable/pocket HDD are allowed.

gilson_gdit Thu, 03/19/2009 - 04:27
User Badges:

I agree, it makes no sense what so ever, but that is the mandate that came down from our IA team.

Collin Clark Thu, 03/19/2009 - 06:13
User Badges:
  • Purple, 4500 points or more

I hear ya, we can't have camera phones, but we can bring in cameras/camcorders/etc.

Leo Laohoo Thu, 03/19/2009 - 15:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

Try the Solid State Drive option.

Actions

This Discussion