MGCP gateway port rejected

Unanswered Question
Mar 18th, 2009

Hello, I have a 2851 with a EVM-HD-8FXS/DID card configured as a MGCP gateway in a CCM 5.1 cluster environment. All ports appear as registered except the first one which appears as rejected. The config is the same than the others ports. I have reloaded the gateway the problem has not been solved. I'm going to reload the CCM (but I have to do it out of hours) to see if it solves the problem. Any idea?

Best regards.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mightyking Wed, 03/18/2009 - 13:49

I don't think rebooting CCM will resolve the issue. Try to reset the faulty port using "shutdown" and "no shutdown" command under the voice-port. If it doesn't help, unplug the faulty FXS cable and plug it back again.

Make sure you have "service MGCPAPP" configured under dial-peer

ccm-manager mgcp

ccm-manager config server

ccm-manager config

mgcp

mgcp call-agent 2427 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

Try to reset the mgcp by using "no mgcp" and then "mgcp":

router(config)#no mgcp

router(config)#mgcp

MK

victorgarciaternero Wed, 03/18/2009 - 14:53

Thank you for your response. I have tried to reset the port without success. I cannot unplug the cable because I am not phisically in the office where the gateway is installed. The config of MGCP in the gateway is correct (there are seven ports working and one not working in a EVM card). I have try to reset MGCP in the gateway ("no mgcp" and "mgcp"), and I have obtained the same result. Now in RTMT I can see the status reason: DatabaseConfigurationError (before that it showed CallManagerReset).

voice-port 2/0/0

cptone ES

!

voice-port 2/0/1

cptone ES

!

voice-port 2/0/2

cptone ES

!

voice-port 2/0/3

cptone ES

!

voice-port 2/0/4

cptone ES

!

voice-port 2/0/5

cptone ES

!

voice-port 2/0/6

cptone ES

!

voice-port 2/0/7

cptone ES

ccm-manager redundant-host 10.1.80.5

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 10.50.80.6

ccm-manager config

!

mgcp

mgcp call-agent 10.50.80.6 2427 service-type mgcp version 0.

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

mgcp package-capability pre-package

no mgcp package-capability res-package

no mgcp package-capability fxr-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp rtp payload-type g726r16 static

!

mgcp profile default

dial-peer voice 999200 pots

service mgcpapp

port 2/0/0

!

dial-peer voice 999201 pots

service mgcpapp

port 2/0/1

!

dial-peer voice 999202 pots

service mgcpapp

port 2/0/2

!

dial-peer voice 999203 pots

service mgcpapp

port 2/0/3

!

dial-peer voice 999204 pots

service mgcpapp

port 2/0/4

!

dial-peer voice 999205 pots

service mgcpapp

port 2/0/5

!

dial-peer voice 999206 pots

service mgcpapp

port 2/0/6

!

dial-peer voice 999207 pots

service mgcpapp

port 2/0/7

2/0/0 does not work, 2/0/1-7 work perfectly.

Regards

victorgarciaternero Thu, 03/19/2009 - 06:08

I have done what you say. This is the result:

Mar 19 13:05:17.972: %LINK-3-UPDOWN: Interface Foreign Exchange Station 2/0/0, changed state to Administrative Shutdown

Mar 19 13:05:20.544: MGCP Packet sent to 10.50.80.6:2427--->

NTFY 364027802 [email protected] MGCP 0.1

X: 0

O:

<---

Mar 19 13:05:20.548: MGCP Packet received from 10.50.80.6:2427--->

200 364027802

<---

Mar 19 13:05:21.696: %LINK-3-UPDOWN: Interface Foreign Exchange Station 2/0/0, changed state to up

(10.112.0.1)

Mar 19 13:05:35.544: MGCP Packet sent to 10.50.80.6:2427--->

NTFY 364027803 [email protected] MGCP 0.1

X: 0

O:

<---

Mar 19 13:05:35.548: MGCP Packet received from 10.50.80.6:2427--->

200 364027803

<---

Regards.

Actions

This Discussion