CIPC and Wireless Problems

Unanswered Question
Mar 18th, 2009

Hello all:

I'm struggling with this issue since long time.

I have a CIPC (ver that works fine in the Company LAN.

When I try to use it at home, where I have a Cisco Linksys Wireless router (connected to ADSL modem), and I try to use CIPC, (using Client VPN to connect to the Company), the VPN connects fine, but the CIPC keeps on "registering" status.

But when I connect to VPN using UTP cable connected to router, CIPC works fine!

I'm going crazy...

Anyone can help?

Thanks in advance


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
david-lima Wed, 03/18/2009 - 19:34

Hi Walter, sorry if I'm missunderstanding your issue, but IP Phones are registered with CCM using MAC address, probably you have configured the MAC of your fast-ethernet port on the CCM, to use Wireless connection, you need to configure the MAC of your wireless adapter too.

Hope this help


walter.perera Thu, 03/19/2009 - 05:02

Hello David.

Thanks for your reply. From other people experience, that have the same CIPC and wireless Linksys, they can connect using VPN and Wireless without configuring Wireless MAC.

Thanks again.


david-lima Thu, 03/19/2009 - 06:28

Hi Walter, in your CCM, do you have auto-registration enable?

Best regards


mightyking Thu, 03/19/2009 - 06:54

Make sure that you can ping the CCM.

Open your IP Communicator and right click on the screen. Selecet "Preference" and then go to "Network" tab.

What is the Mac Address selected for "Device Name"? Is it the Mac Address of your network card or the Mac Address of the VPN? From the drop down menu, switch the Mac Address. Close the IP Communicator and reopen it.


walter.perera Thu, 03/19/2009 - 11:34

Hi MK:

I can ping CCM. The MAC that IP phone is using is the NIC MAC.



david-lima Thu, 03/19/2009 - 12:01

Hi Walter, also verify that the selected MAC (VPN or Wireless adapter) is already register in your CallManager (Device->Phone->SEPMACVPN or Wireless).

All the best


walter.perera Thu, 03/19/2009 - 15:30

Hi David:

We tried by changing network interface in the CIPC, but no result. It should have auto registered but, it didn't.

What is most crazy about this is that some other people that have same connectivity, do not have issues, while others have different kind of issues, such as, not being able to be heard by the other party involved....

Thanks for all your support

j.mccartney Fri, 03/20/2009 - 14:39

We had random problems with UPC not IPC, we had to remove the following statements from our ASA:

no inspect h323 h225

no inspect h323 ras

no inspect skinny

no inspect sip

Not sure if that will help you.

walter.perera Thu, 03/26/2009 - 13:17

Hi J.

In fact our firewall is Checkpoint (as well as VPN client).

As a reference you can find the results from Wireshark when using wireless and wired.

walter.perera Mon, 04/13/2009 - 06:54

Hi all:

Finally (and unluckly) I have found the solution.

I have installed a DD-WRT firmware on my Linksys router and, it works!

I did not make any config changes, only basic PPPOE config.

Linksys should take care of this I think.

Thanks for all.



walter.perera Mon, 04/13/2009 - 07:31

Hi Jeff:

Thanks for your info, but TFTPs are configured manually in the softphone.


wrickk_2 Thu, 04/16/2009 - 20:28

If the NIC is an Intel Pro 1000 there is an option called Deep Smart Power Down. If this is enabled (default) it causes the Ethernet NIC to "disappear" when the notebook is not plugged into an external power source and the NIC is not in use. When that happens CIPC can no longer register with CUCM. You can disable this under the NIC properties. Also, it doesn't make any difference which MAC you use as long as it is the same one configured on the CUCM, you can make one up for that matter.


This Discussion