ACE Ether Channel to Core Switch

Unanswered Question
Mar 19th, 2009

Hello,

I have a 2 gig license on the my ACE 4710 Appliance. I would like to configure an ether channel bundle from the ACE to my core switch. Below is my configuration. Please let me know if I am on the right track. Your help is greatly appreciated.

Thanks,

ACE Ether Channel to Core Switch

:STEP 1 Configuring Ethernet Channel on Admin Context

ACE4710/Admin(config)# interface gigabitEthernet 1/1

ACE4710/Admin(config-if)# channel-group 1

ACE4710/Admin(config-if)# no sh

ACE4710/Admin(config)# interface gigabitEthernet 1/2

ACE4710/Admin(config-if)# channel-group 1

ACE4710/Admin(config-if)# no sh

ACE4710/Admin(config-if)# exit

ACE4710/Admin(config)# interface port-channel 1

ACE4710/Admin(config-if)# switchport trunk allowed vlan 10,100

ACE4710/Admin(config-if)# switchport trunk native vlan 1

ACE4710/Admin(config-if)# no shutdown

ACE4710/Admin(config-if)# end

:STEP 2 Configuring Vlan IP Address on Admin Context

ACE4710/Admin(config)# interface vlan 100

ACE4710/Admin(config-if)# ip address 10.0.100.1 255.255.255.0

ACE4710/Admin(config-if)# no sh

:STEP 3 Configuring Vlan IP Address on Virtual Context

VLAN 100

ACE4710/VC_Prod(config)# interface vlan 100

ACE4710/VC_Prod(config-if)# ip address 10.0.100.2 255.255.255.0

ACE4710/VC_Prod(config-if)# no sh

VLAN 111

ACE4710/VC_Prod(config)# interface vlan 111

ACE4710/VC_Prod(config-if)# ip address 10.0.10.10 255.255.255.0

ACE4710/VC_Prod(config-if)# no sh

:STEP 4 Core Switch Ethernet Channel Configuration

interface Port-channel6

description ACE Port Channel

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100, 111-113

no ip address

interface GigabitEthernet9/20

description ACE Ethernet Channel

switchport

channel-group 6 mode on

no ip address

interface GigabitEthernet10/3

description ACE Ethernet Channel

switchport

channel-group 6 mode on

no ip address

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dario.didio Thu, 03/19/2009 - 07:19

Hi,

What are you trying to accomplish?

Your config of the etherchannel on your ACE is OK.

you are trunking VLAN 10 and 100 to your core switch. I assume this will be the client and server VLAN?

If I was you, I would add another VLAN for management purpose and assign it to the Admin context. Don't forget to add it to the trunk allowed vlan list!

You configure an IP Address in you Admin context for VLAN 100 (management I assume) and an IP Address in your context, also for VLAN 100. That's why I would recommend a management VLAN used in the Admin context.

You configure VLAN 10 and 100 on the trunk from the ACE to the core switch, and on your core switch you configure VLAN 100,111,112 and 113. Make sure that the VLANs you need are allowed on both sides.

Your members of you etherchannel should have the same config as the etherchannel:

interface Port-channel6

description ACE Port Channel

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100, 111-113

no ip address

interface GigabitEthernet9/20

description ACE Ethernet Channel

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100, 111-113

channel-group 6 mode on

no ip address

interface GigabitEthernet10/3

description ACE Ethernet Channel

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 100, 111-113

channel-group 6 mode on

no ip address

but it's possible the switch does it by itself, depending on your IOS release.

You can check if the etherchannel is up:

show etherchannel summary

HTH,

Dario

allen.malanda_2 Thu, 03/19/2009 - 07:27

Hello,

Is it ok to configure a management vlan for the Admin context and all my virtual context? I want to be able to telnet directly to a virtual context instead of doing the changeto command on the admin context. Can I share vlans between context?

dario.didio Mon, 03/23/2009 - 01:44

Hello,

yes you can share a single VLAN over multiple contexts.

"The ACE also supports shared VLANs, which are multiple interfaces in different contexts on the same VLAN within the same subnet. Only routed interfaces can share VLANs. Note that there is no routing across contexts even when shared VLANs are configured."

allen.malanda_2 Mon, 03/23/2009 - 10:01

hello,

Thank you very much for the info, I will implement these changes this weekend. I will late you know how it turns out. Please feel free to send me any URL concerning this configuration.

Thanks,

Actions

This Discussion