vmiller Thu, 03/19/2009 - 09:36
User Badges:
  • Gold, 750 points or more

From the config guide:

The DHCP server feature is only available on Catalyst 2955 switches.

Leo Laohoo Thu, 03/19/2009 - 15:03
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

The 2950 is not capable of being a DHCP server. This feature started with the 2970 and was incorporated to the 2960/2975 series of switches.

Cisco_Bob Tue, 07/17/2012 - 16:14
User Badges:

I know this is a real old post but you can use a 2950 switch as a DHCP Server. You just need to start the service first, then configure it just like a router. I did it on one of my 2950 switches to test after I saw a video on YouTube where someone did it. As he mentions, this could do more harm then good because of the lack of controling broadcasts.


http://www.youtube.com/watch?v=Fa83TCPwOlU


This is from my switch


hostname Switch1

!

!

ip subnet-zero

ip dhcp excluded-address 192.168.50.0 192.168.50.10

!

ip dhcp pool TEST

   network 192.168.50.0 255.255.255.0

!

ip ssh time-out 120

ip ssh authentication-retries 3

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

switchport access vlan 50

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 50

switchport mode access

Actions

This Discussion