UCCX 7 system scripts

Unanswered Question
Mar 19th, 2009
User Badges:

I've edited icd.aef, and when i do the system will not initiate the script (plays the sorry, experiencing problems prompt). If i change it back to the original, it works.


Now, I've accidentally overwritten the original and it won't work. All of the steps are exactly the way they were.


Can you edit the default system scripts in 7.0 ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jonathan Schulenberg Thu, 03/19/2009 - 18:27
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Validate the script in the CRS editor. It should tell you where the error is.

allenelson Thu, 03/19/2009 - 20:43
User Badges:

I have validated the script but there are no errors.

Anthony Holloway Fri, 03/20/2009 - 21:36
User Badges:
  • Purple, 4500 points or more

Someone attach their 7x icd.aef so he can have an original copy.

toormehdi Sat, 01/02/2010 - 12:52
User Badges:

I am having the exam same problem. Were you able to figure it out?

Russell La Plante Mon, 01/04/2010 - 08:43
User Badges:

Here is a copy of the 7x icd.aef.  Replicate the error and look at the latests log file in Program Files\wfavvid\log\MIVR.  The error will be in there. you can  attach it also but be mindful if there are passwords in the script they will be included.

Attachment: 
toormehdi Mon, 01/04/2010 - 08:50
User Badges:

Thanks for your help Russell.


However, I did find the bug. It appears to be that UCCX 7.0 doesnt like any new script or even the original script opened in editor and saved back to the system default directory (without even making changes) fails after application refresh. It doesnt like anything in the system default scripts folder under wfavvid except the files which came along with it.


I was able to create, edit, save scripts in a folder other than system default, uploaded the script and it worked perfectly fine.


I don't know why is that, but it would have been great if you can save it in system folder and one doesnt have to upload the script, because I saw that it gets itself available for selection without uploading if its saved in there.

sjain2 Tue, 01/05/2010 - 17:00
User Badges:

Hi,



In the UCCX 7.0 after editing any script you need to re-upload the script and refresh the appication. simply editing and saving the script in the system default or at some other place will not actually make the CRS system use the new edited script.


In previous uccx version specifically uccx 4.0 and below it was possible when you save the script in the system default folder but not in uccx 7.0


this is working as designed. hope this will help.

yavuzsab Sun, 12/15/2013 - 15:23
User Badges:

Hello,  We are experiencing the same exact issue for my client with UCCX 7.0(1)SR5 HA. Do you have the bug ID or workaround/fix?  Thank you, Yav

Gergely Szabo Mon, 12/16/2013 - 07:53
User Badges:
  • Green, 3000 points or more
  • Community Spotlight Award,

    Member's Choice, December 2015

Hi,

well, the workaround is to upload the script to the repository.

G.

Actions

This Discussion