Spanning Tree Cost

Answered Question

Can "spanning-tree cost" and "spanning-tree vlan 200 cost" both be used on the same interface at the same time?

My goal would be to set a new default cost for all vlans and modify just one or two from that new default.

Thank You

I have this problem too.
0 votes
Correct Answer by Giuseppe Larosa about 7 years 8 months ago

Hello Jeff,

yes this is possible there is no ambiguity in these two commands

I tried on a ge port of a C4500

sh run int g1/4

Building configuration...

Current configuration : 256 bytes

!

interface GigabitEthernet1/4

description link verso RT-RM-SXR000-SF-I-E-2

switchport trunk encapsulation dot1q

switchport mode trunk

storm-control broadcast level 1.00

spanning-tree guard loop

spanning-tree vlan 4 cost 6

spanning-tree cost 4

end

sh spanning-tree vlan 4 int g1/4

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0004 Altn BLK 6 128.4 P2p

SW-RM-SXR000-SF-I-C-2#sh spanning-tree vlan 2 int g1/4

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0002 Root FWD 4 128.4 P2p

Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Giuseppe Larosa Fri, 03/20/2009 - 10:54

Hello Jeff,

yes this is possible there is no ambiguity in these two commands

I tried on a ge port of a C4500

sh run int g1/4

Building configuration...

Current configuration : 256 bytes

!

interface GigabitEthernet1/4

description link verso RT-RM-SXR000-SF-I-E-2

switchport trunk encapsulation dot1q

switchport mode trunk

storm-control broadcast level 1.00

spanning-tree guard loop

spanning-tree vlan 4 cost 6

spanning-tree cost 4

end

sh spanning-tree vlan 4 int g1/4

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0004 Altn BLK 6 128.4 P2p

SW-RM-SXR000-SF-I-C-2#sh spanning-tree vlan 2 int g1/4

Vlan Role Sts Cost Prio.Nbr Type

---------------- ---- --- --------- -------- --------------------------------

VLAN0002 Root FWD 4 128.4 P2p

Hope to help

Giuseppe

Actions

This Discussion