CaT 6500 problem with dot1q trunk to HP BL-C Blade Switch

Unanswered Question
Mar 20th, 2009

Not sure if anyone out there has a C-Class HP Blade server enclosure with a 10Gig HP BL-C Switch connected to a core 6500 using 802.1q trunk and EtherChannel:

Anyway, having issue with conenctivity:

I set up the dot1q trunks and added members on the BL-C, andl am unable to get the servers to talk thru the switches and the Cisco core (setup to allow default-all vlans)

Here is the scenario

- Servers are VM ESX 3.5. VMware is tagging using VST- where the V-switch is tagging, like in the document:

http://www.vmware.com/pdf/esx3_vlan_wp.pdf

- Here is the BL-C config (truncated)

/c/port 1

tag ena

/c/port 2

tag ena

/c/port 3

tag ena

/c/port 18

tag ena

/c/port 19

tag ena

/c/l2/vlan 2

ena

name "network"

def 1 2 3 18 19

/c/l2/vlan 3

ena

name "infrastructure"

def 1 2 3 18 19

/c/l2/vlan 4

ena

name "devtest"

def 1 2 3 18 19

/c/l2/vlan 5

ena

name "vpn"

def 1 2 3

/c/l2/vlan 6

ena

name "stage"

def 1 2 3 18 19

/c/l2/vlan 8

ena

name "iscsi"

def 1 2 3 18 19

/c/l2/vlan 10

ena

name "corecard"

def 1 2 3 18 19

/c/l2/vlan 20

ena

name "ecommerce"

def 1 2 3 18 19

/c/l2/vlan 30

ena

name "sql"

def 1 2 3 18 19

/c/l2/vlan 40

ena

name "blades1"

def 1 2 3 18 19

/c/l2/vlan 41

ena

name "vmbuild"

def 1 2 3 18 19

/c/l2/vlan 50

ena

name "blades2"

def 1 2 3 18 19

/c/l2/vlan 60

ena

name "blades3"

def 1 2 3 18 19

/c/l2/vlan 70

ena

name "blades4"

def 1 2 3 18 19

/c/l2/vlan 80

ena

name "AspectUIP"

def 1 2 3 18 19

/c/l2/vlan 192

ena

name "management"

def 1 2 3 18 19

/c/l2/stp 1/off

/c/l2/stp 1/clear

/c/l2/stp 1/add 1 2 3 4 5 6 8 10 20 30 40 41

/c/l2/stp 1/add 50 60 70 80 192

/c/l2/stp 1/port 1/on /fastfwd enabled

/c/l2/stp 1/port 2/on /fastfwd enabled

/c/l2/stp 1/port 3/on /fastfwd enabled

/c/l2/stp 1/port 18/off

/c/l2/stp 1/port 19/off

/c/l2/trunk 2

ena

add 18

add 19

/c/sys/syslog

host 10.20.3.24 -mgt

host2 10.20.2.30 -data

facil2 5

/c/ufd/on

/* /c/l3/if 250

* addr

* ena

/* /c/l3/gw 254

* ena

* addr

- Here is the Cisco Core switch config (truncated):

interface Port-channel100

description 20 Gbps trunk to Core2 t1/1 t1/9

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast disable

interface TenGigabitEthernet1/1

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast disable

spanning-tree link-type point-to-point

channel-group 100 mode on

interface TenGigabitEthernet1/9

switchport

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast disable

spanning-tree link-type point-to-point

channel-group 100 mode on

I verified the Etherchannel is up

No traffic seems to pass (dhcp requests, pings to static IP, etc)

Any ideas on what is wrong?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Yudong Wu Sat, 03/21/2009 - 12:00

There are two trunks here.

- trunk between server and Blade switch

- trunk between blade switch and core switch.

Could you verify if both trunks are up?

Cisco command should be "sh int trunk".

The other thing is that Cisco does not tag native vlan on a trunk by default. So, you need to make the sure the other side does not tag native vlan as well.

By the way, have you created all the vlans on CAT6k swtich?

Yudong Wu Thu, 03/26/2009 - 14:20

1. Can you post output "show int trunk Gigx/y"

2. Did you check if all vlan is active in CAT6500?

3. My understanding is that there is another trunk between BL-C and server, is it correct? If yes, does that trunk up?

4. Configure a management IP on BL-C if possible, then configure a vlan interface (in the same management vlan) on CAT6500, try to ping BL-C IP to see if trunk can pass traffic correctly.

Actions

This Discussion