QoS cisco 1841 - ios won't let me set correct UBR value ?

Unanswered Question

Hi, easy one this! (hopefully)

I am trying to set up QoS on a pvc on a 5Mb adsl line :

tranetvpn1(config-subif)#pvc

tranetvpn1(config-subif)#pvc 0/

tranetvpn1(config-subif)#pvc 0/38

tranetvpn1(config-if-atm-vc)#ubr

tranetvpn1(config-if-atm-vc)#ubr ?

<32-832> Peak Cell Rate (PCR) in Kbps

but it will not let me enter above 832 as a peak cell rate - why is this ?

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.

This is the config that I am trying to add QoS onto :

class-map match-all pbx-vosig

match access-group 105

class-map match-all voip-adsl

match access-group 102

class-map match-all vosig-adsl

match access-group 103

class-map match-all pbx-adsl

match access-group 104

!

!

policy-map PBX

class pbx-vosig

set ip dscp cs5

class pbx-adsl

set ip dscp ef

class class-default

set ip dscp default

policy-map LLQ

class voip-adsl

set precedence 1

priority percent 70

class vosig-adsl

bandwidth remaining percent 4

set ip dscp default

class class-default

set ip dscp default

!

!

!

crypto isakmp policy 10

encr 3des

authentication pre-share

group 2

crypto isakmp key xxx address xxx

crypto isakmp keepalive 10

!

!

crypto ipsec transform-set 3desmd5 esp-3des esp-md5-hmac

crypto ipsec df-bit clear

!

crypto map tranetvpn 50 ipsec-isakmp

set peer x

set transform-set 3desmd5

match address a1

reverse-route

!

!

!

!

interface Loopback0

no ip address

!

interface FastEthernet0

no ip address

shutdown

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface ATM0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.2 point-to-point

bandwidth 4096

no ip redirects

no ip proxy-arp

no snmp trap link-status

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Vlan1

description ***LAN IP ADDRESS***

ip address 10.0.0.11 255.255.255.0 secondary

ip address 192.168.120.240 255.255.255.0

no ip redirects

no ip proxy-arp

ip virtual-reassembly

ip tcp adjust-mss 1452

service-policy input PBX

!

interface Dialer0

ip address x 255.255.255.254

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxx

ppp chap password 7 xxx

ppp pap sent-username xxx

24B

crypto map tranetvpn

!

ip route 0.0.0.0 0.0.0.0 192.168.120.251

!

!

no ip http server

no ip http secure-server

!

ip access-list extended a1

permit ip 192.168.120.0 0.0.0.255 192.168.121.0 0.0.0.255

permit ip any 192.168.121.0 0.0.0.255

!

access-list 102 permit udp any any dscp ef

access-list 103 permit tcp any eq 1720 any

access-list 103 permit tcp any any dscp cs5

access-list 105 permit tcp any any eq 1720

ok, think I have worked it out after doing a lot of reading, the upsteam bandwidth is 832.

tranetvpn1#show atm interface atm 0.2

Interface ATM0:

AAL enabled: AAL5 AAL2, Maximum VCs: 23, Current VCCs: 1

VCIs per VPI: 1024,

Max. Datagram Size: 4528

PLIM Type: ADSL - 832Kbps Upstream, DMT, TX clocking: LINE

15251 input, 18881 output, 121400 IN fast, 88626 OUT fast

Avail bw = 832

Config. is ACTIVE

tranetvpn1#

Paolo Bevilacqua Sat, 03/21/2009 - 11:42

Right. in ADSL, A means Asymmetric.

You will also find that setting Cell Rate explicitly is not necessary, the router do that automatically.

I had to set the cell rate explicitly , otherwise it's not possible to put the service policy on the pvc.

I've been reading lots about atm, but I'm still confused, does the ubr rate command (say 'ubr 832') only apply to the upstream bandwidth?

Will this limit the rate that the router can transmit at, but it will still be able to receive data at rates up to 5Mb ?

Thanks for the reply

Paolo Bevilacqua Sat, 03/21/2009 - 15:54

Yes, the command influences transmission only, and has no effect whatsoever on receiving.

Actions

This Discussion