CLID and name

Unanswered Question
Mar 20th, 2009

I am having trouble configuring my system to allow CLID and name to show up on calls outbound to METRO numbes in our area. I did a debug isdn q931 but it shows my callgoing out as my 4-digit extension (3319) and not the full 10-digit number that I see when I do a trace in the dialed number analyzer. Any suggestions are welcome. See attachment

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
j.mccartney Mon, 03/23/2009 - 09:59

Sorry about that - we are using CUCM6.1.2.1112-2 with H.323 gateways.

j.mccartney Tue, 03/24/2009 - 09:05

Hi Paul,

I did find soemthing that may impact my issue. I found that on our primary gateway in CUCM we didn't have the "Display IE Delivery" checkbox under Call Routing Information - Outbound Calls. I have reset it but will have to wait till afterhours to reset the VG.

Paolo Bevilacqua Tue, 03/24/2009 - 10:39

No problem. To send out 10 digits:

voice translation-profile make10

translate calling 10

voice translation-rule 10

rule 1 // /888555/ plan any idsn type any national

voice port 0/y/z:23

translation-profile make10 outgoing

Note this may not work for forwarded depending if you telco accepts any CLID or not.

j.mccartney Tue, 03/24/2009 - 12:01

Wouldn't this dialpeer do what I want as it fowrds 10 digits? I'll check with our carrier to see if they are allowing it or translating to something else too.

dial-peer voice 5 pots

description ** Local 10 Digit **

destination-pattern 9830.......

port 0/0/0:23

forward-digits 10

Paolo Bevilacqua Tue, 03/24/2009 - 19:05

It forwards 10 digits for called number. Your concern is for calling number.

However, for local calls you should use:

destination-pattern 9[2-9][0-9][0-9]....

You might be billed for long distance when dialing local numbers with an area code.

Actions

This Discussion