EIGRP question

Unanswered Question

To all,

I have a minor issue. Is there a way to weight a route within EIGRP.


SiteWIN - VPN (192.168.101.x) - CORP

SiteWIN - PTP t-1 (10.103.1.x) - SiteMSP


SiteMSP - MPLS t-1 (172.20.x.x) - CORP

SiteMSP - PTP t-1 (10.103.1.x) - SiteWIN


Right now, EIGRP uses the PTP to another branch office (SiteMSP) as the primary route and will failover to VPN if the s1/0 goes down. I want to weight the 192.168.101.x route as the primary and failover to the PTP if the VPN goes down. Is there a way to do this? I have included a sanitized version of my config.


My guess is I am going to have to use SLA w/ static routes but would like a second opinion...


Any inut would be greatly appreciated!


!IOS 12.4.18 AdvSec

!WIN-config sanitized

version 12.4

hostname WIN-1760

!

ip cef

!

!

crypto isakmp policy 1

encr aes 256

authentication pre-share

group 5

crypto isakmp key somekey address 207.x.x.x

!

!

crypto ipsec transform-set myset esp-aes 256 esp-sha-hmac

!

crypto map myset 10 ipsec-isakmp

set peer 207.x.x.x

set transform-set myset

match address 101

!

!

!

interface Tunnel0

description GRE to CORP

ip address 192.168.101.2 255.255.255.252

no ip redirects

no ip unreachables

ip nbar protocol-discovery

ip route-cache flow

ip tcp adjust-mss 1436

tunnel source Ethernet0/0

tunnel destination 10.99.1.1

!

interface Null0

no ip unreachables

!

interface Ethernet0/0

ip address 69.x.x.1 255.255.255.252

ip access-group 103 in

ip verify unicast reverse-path

no ip redirects

no ip unreachables

ip nbar protocol-discovery

ip inspect standard out

ip route-cache flow

full-duplex

crypto map myset

!

interface FastEthernet0/0

description WIN LAN

ip address 10.101.2.1 255.255.255.0

ip access-group 102 in

ip helper-address 10.1.1.104

no ip redirects

no ip unreachables

ip nbar protocol-discovery

ip route-cache flow

speed auto

!

interface Serial1/0

description WIN_PTP_MSP

ip address 10.103.1.1 255.255.255.252

ip verify unicast reverse-path

no ip redirects

no ip unreachables

ip nbar protocol-discovery

ip route-cache flow

!

router eigrp 333

passive-interface Ethernet0/0

network 10.0.0.0

network 192.168.101.0 0.0.0.3

no auto-summary

!

ip forward-protocol nd

ip route 10.99.0.0 255.255.0.0 69.x.x.2

ip route 207.x.x.x 255.255.255.0 69.x.x.2


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Sun, 03/22/2009 - 18:49
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Mark


I believe that there is a solution that is much less complex than implementing IP SLA and static routes. You can configure an offset list under EIGRP which will add an amount to the metric for the route through the PTP T1 and make it less desirable than the route through the VPN, which is essentially a solution to weight the route within EIGRP.


In its simple form you might configure something like this under router eigrp:

offset-list 0 in serial1/0

and it would add the to the metric of all routes learned over serial1/0. You might need to experiment a bit to find the value that you need to add that is sufficient to make the routes less favorable. If you need to influence only certain EIGRP routes there is a version of the offset list that uses an access list to identify the prefixes to which you add the value:

offset-list 50 in serial1/0

where access list 50 identifies the prefixes to which you will add the value.


Give it a try and let us know how it works.


HTH


Rick

Actions

This Discussion