2960 half duplex trunk to 3560

Unanswered Question

a switch that connect to my core L3 3560G switch has duplex mismatch.

it is a cisco 2960 and this is the config of the trunk port:

interface GigabitEthernet0/1

description UPLINK to CORE3560G

end

2960_24port#sh int g0/1

GigabitEthernet0/1 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 001b.531a.0c19 (bia 001b.531a.0c19)

Description: UPLINK to CORE3560G

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 3/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Half-duplex, 100Mb/s, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:00, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 1247000 bits/sec, 190 packets/sec

5 minute output rate 60000 bits/sec, 49 packets/sec

631628665 packets input, 1261340809 bytes, 0 no buffer

Received 442225434 broadcasts (0 multicast)

0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 72230903 multicast, 0 pause input

0 input packets with dribble condition detected

155468085 packets output, 316694810 bytes, 0 underruns

0 output errors, 1037074 collisions, 1 interface resets

0 babbles, 377763 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

this is the config on the core side:

interface GigabitEthernet0/45

description uplink to 2960-24port

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

speed 100

spanning-tree portfast

end

CORE3560G#sh int g0/45

GigabitEthernet0/45 is up, line protocol is up (connected)

Hardware is Gigabit Ethernet, address is 0017.e040.41ad (bia 0017.e040.41ad)

Description: uplink to 2960-24port

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 3/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX

input flow-control is off, output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:08, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 55000 bits/sec, 46 packets/sec

5 minute output rate 1199000 bits/sec, 191 packets/sec

155179851 packets input, 325907696 bytes, 0 no buffer

Received 1734602 broadcasts (0 multicast)

0 runts, 111 giants, 0 throttles

351695 input errors, 351584 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 1276980 multicast, 0 pause input

0 input packets with dribble condition detected

631611144 packets output, 1246708284 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

I see the giants and CRC errors and assume they are a result of the duplex mismatch

all other ports on the 2960 are configured in the same way and automatically go to full duplex

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Blakley Mon, 03/23/2009 - 09:58

You should hardcode 100/full on both sides if you're going to specify it on one.

HTH,

John

glen.grant Tue, 03/24/2009 - 04:51

Seeing that they are both cisco switches just set both sides speed and duplex as auto and it will negotiate 1000/full on its own . Gig does not need to be hardcoded as a rule at least between cisco devices. I have never seen an instance between cisco devices where it failed to negotiate gig.

John Blakley Tue, 03/24/2009 - 05:13

They *should* negotiate, but I've seen it where we've had to hardcode it whether it be IOS revisions or other problems that kept it from negotiating the proper duplex.

And you said "Gig does not need to be hardcoded as a rule", but Cisco has always recommended either hardcoding both sides or setting both sides to auto. If auto's not working correctly (which in this case one side was set), then the only other alternative is to try to set both sides manually.

John

badalam_nt Mon, 03/23/2009 - 11:10

You had the following configuration:

at 2960 side: auto

at 3560 side: 100Mb/s, full duplex

As a result, at 2960 side the speed will get the same as at 3560 side: 100Mb/s, but the duplex mode (which can be negotiate only if at both sides the duplex is set to auto) will fall-back to half duplex.

So in order to get rid of the duplex mismatch, either you set the duplex to Auto at both sides or set manually the same duplex mode (full) at both sides.

tom_fox_ki4qqq Tue, 03/24/2009 - 06:58

That's because at gigabit speeds, the only available duplex option is full.

Personally, I always nail trunk links to a certain speed and duplex, even if gigabit.

Actions

This Discussion