blocking multicast on layer 2 3750

Answered Question
Mar 23rd, 2009
User Badges:


I have a 3750-e, without routing or multicast enabled. there are two switch ports which uplink a firewall and router that are supporting multicast. How would one block multicast traffic on ports that don't need multicast and still support multicast, in this case, on the ports that do?


thanks, Kevin

Correct Answer by Jon Marshall about 8 years 3 months ago

Kevin


IGMP snooping should be enabled by default. This is all you really need to meet your requirement -


http://www.cisco.com/en/US/docs/switches/lan/catalyst3750e_3560e/software/release/12.2_46_se/configuration/guide/swigmp.html#wp1089644


Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jon Marshall Mon, 03/23/2009 - 14:54
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Kevin


Not entirely sure i understand what you are asking. Do you mean you want multicast packets to go through the switch but only on the relevant ports ?


If so you need to turn on IGMP snooping on the 3750-e switch.


If not please clarify.


Jon

ksvy_ksvy Mon, 03/23/2009 - 15:03
User Badges:


hi Jon, yes, correct


multicast isn't enabled, but I want to allow it only an couple ports. I found the "switchport block multicast" command, but my boss mentioned to make sure to use igmp snooping. What are the commands for these two options?


thanks, Kevin

Leo Laohoo Mon, 03/23/2009 - 15:40
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

"multicast isn't enabled"

What's your IOS and Feature?

Actions

This Discussion