RME 4.2 - SWIM job downloading a tar image twice?

Unanswered Question
Mar 24th, 2009

Customer has setup a SWIM job for cat3560 to deploy c3560-ipbasek9-mz.122-46.SE.tar.

looking into the job logs we found that the command

archive download-sw /overwrite tftp://1.1.1.1/rep_sw_5728568740407592606

seems to download the image 2 times in a row:

[...]

Loading rep_sw_5728568740407592606 from 1.1.1.1 (via Vlan110): !!!!!!!!

[OK - 11233280 bytes]

Loading rep_sw_5728568740407592606 from 1.1.1.1 (via Vlan110): !!!!!!!!

examining image...

extracting info (105 bytes)

extracting c3560-ipbasek9-mz.122-46.SE/info (446 bytes)

extracting info (105 bytes)

[...]

when doing the same command in cli on the switch, like this

archive download-sw /overwrite tftp://1.1.1.1/c3560-ipbasek9-mz.122-46.SE.tar

it is exactly the same behaviour;

this was verified with

c3560-ipbasek9-mz.122-46.SE.tar

c3560-ipbasek9-mz.122-50.SE.tar

is this is bug or expected behaviour??

Attached are the logs for one of the devices from the job.

Ah, and by the way, for what is the xxx_Config_Snap file used that is in the job directory?

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 03/24/2009 - 09:52

This is the correct behavior. The switch does this to determine adequate space and memory. I actually have a bug against RME pertaining to an issue where this double-download can cause a SWIM Failure. The bug is CSCsq80133.

The Snap files are config store the config commands to be added to the device (e.g. new boot commands).

Martin Ermel Tue, 04/07/2009 - 06:15

this sounds strange, downloading the same file twice... but ok, if it works as designed there must be a reason behind this method.

Is there a patch available for CSCsq80133? When we setup a swim job we actually see some devices failing while others gets updated correctly. This is a big issue for the customer because they have plenty of 2960 and 3750 in the network and they need to do the software update with RME.

Joe Clarke Tue, 04/07/2009 - 09:00

I did write a patch for this against an old version of LibSwim. I cannot update it due to lack of code, but development might be able to create an updated patch for the latest LibSwim. In any event, my fix was merged into RME 4.3, and will be available when LMS 3.2 is released.

Martin Ermel Tue, 04/07/2009 - 11:16

if the fixed version of LibSwim is part of RME 4.3 would it be possible to replace the actual LibSwim from RME 4.2 with the one from RME 4.3 or do you know if there are special dependencies on other packages or for other packages ?

Or do I have to just try and test this?

Joe Clarke Tue, 04/07/2009 - 11:35

You cannot replace the RME 4.2 LibSwim with one from RME 4.3. You would need an RME 4.2 LibSwim built with the current RME 4.2 code.

Actions

This Discussion