LACP, 4500, and Non-LACP Links

Unanswered Question
Mar 24th, 2009

I have a 4506 running IPBASE IOS 12.2(25)SG1. It supports a high-performance computing research area with about 20 servers that get repurposed and rebuilt every so often. Each server has a built-in NIC with two gig Ethernet ports (Penguin Computing Altus 1300 servers).

I configured the switch ports to do LACP EtherChannel. It works just fine.

However, when a server needs to be repurposed, they boot it from BIOS using PXE. Unfortunately, the switch does not allow access to the network because it objects to the device not using LACP. If we hook up the same server to a 6513 running IPSERVICESK9_WAN IOS 12.2(18)SXF11, it allows the server to use a link. show eth sum shows the link to be in independent mode.

I have tried changing the LACP mode on the interfaces to both active and passive (the 6513 has them configured as active, which is the one that works). Neither mode works to allow independent service on the 4506.

Is this because the 4506 is running an IPBASE version of IOS? Is this a bug in either the 6513 or 4506's code? I didn't see any errors related to this in the Bug Toolkit for the 4506's code (and I admittedly haven't check the 6513 yet). But one of them isn't working the way it should, whether the 6513 is allowing an independent connection when it shouldn't or the 4506 isn't allowing an independent connection when it should.

The error I'm getting: %EC-5-L3DONTBNDL2: Gi4/14 suspended: LACP currently not enabled on the remote port

This does NOT allow independent service on the 4506 (doesn't matter whether active or passive in testing):

interface GigabitEthernet4/14

description 2Q-10B

switchport access vlan 39

switchport mode access

logging event link-status

channel-group 34 mode passive

spanning-tree portfast

end

This one DOES allow independent service on the 6513:

interface GigabitEthernet4/1

switchport

switchport access vlan 39

switchport mode access

no ip address

spanning-tree portfast

channel-group 20 mode active

end

Suggestions?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mfarrenkopf Mon, 03/30/2009 - 13:01

Thank you. I see where you're getting that and I understand. However, the link is most definitely not L3. The port-channel configuration is also L2. From the 4506 (which does not go into independent mode):

interface Port-channel39

description 2R-5A/B

switchport

switchport access vlan 39

switchport mode access

spanning-tree portfast

end

From the 6513 (which does go into independent mode):

interface Port-channel20

description EC for 11/1-2 & 12/1-2

switchport

switchport access vlan 39

switchport mode access

no ip address

end

The 4506 is a L2 switch. It does not do any routing. The 6513 is the router for VLAN 39.

A laptop plugged into the 4506 causes the error message, whereas the exact same laptop gets independent service from the 6513 without any configuration changes to the laptop. I would think if this is a layer 3 issue that it would be the 6513 with the routing instance that causes the issue. But it's not.

Any other ideas?

Edison Ortiz Mon, 03/30/2009 - 13:15

That's odd, passive shouldn't send LACP packets.

Can you try creating a new port-channel?

Something like

channel-group 35 mode passive

___

Edison.

mfarrenkopf Mon, 03/30/2009 - 13:22

Thanks for the reply. I can coordinate such a test. It will probably be Friday before I can do that.

I haven't done a capture to see what's happening. However, I'm more inclined to think that, although marked as passive, the switch is expecting the host to negotiate LACP (while the switch isn't sending LACP packets itself in passive mode). It doesn't receive an LACP negotiation, thinks it's supposed to be LACP, and pitches a fit about it not being an LACP link.

That would explain the error message and still not have the switch initiate LACP packets.

But I'm just guessing here.

I'll work on creating a separate, new port-channel. I don't expect any differences, but I'll try it.

Actions

This Discussion