ipip tunnel on cisco 1841

Unanswered Question
Mar 25th, 2009

Hi,

i want to configure ipip tunnle on cisco 1841 device.

two tunnles (tunnle 100 and tunnle 200)

i configured Fe0/0 ip address: 10.10.10.4

And the tunnels configuration is:

interface Tunnel100

ip address 50.50.50.50 255.255.255.0

ip helper-address 192.90.91.1

tunnel source 10.10.10.4

tunnel destination 10.10.10.3

tunnel mode ipip

!

interface Tunnel200

ip address 60.60.60.60 255.255.255.0

ip helper-address 192.90.91.1

tunnel source 10.10.10.8

tunnel destination 10.10.10.7

tunnel mode ipip

now only tunnle 100 is working fine.

if i changing the Fe0/0 ip address to 10.10.10.8

only tunnle 200 is working.

i cannot configure both ip addresses:

10.10.10.4 and 10.10.10.8 on the same router because they on the same subnet.

what can i do?

another question, what is the meaning of configuring the "ip address" command inside tunnel configuratiom mode? in what situations this ip is used? cause as much as i know the tunnle using the ip address on the interface which through it passes.

Thanks for your help!

Alon

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
AlonStyle Wed, 03/25/2009 - 01:56

Cisco1841-IPIP#sh run interface fastEthernet 0/0

Building configuration...

Current configuration : 126 bytes

!

interface FastEthernet0/0

ip address 10.10.10.4 255.255.255.0

ip helper-address 192.90.91.1

duplex auto

speed auto

end

a.alekseev Wed, 03/25/2009 - 02:07

interface Tunnel100

ip address 50.50.50.50 255.255.255.0

ip helper-address 192.90.91.1

tunnel source 10.10.10.4

tunnel destination 10.10.10.3

tunnel mode ipip

!

interface Tunnel200

ip address 60.60.60.60 255.255.255.0

ip helper-address 192.90.91.1

tunnel source 10.10.10.4

tunnel destination 10.10.10.7

tunnel mode ipip

and modify "destination" for the tunnel on 10.10.10.7.

AlonStyle Wed, 03/25/2009 - 03:16

thanks! it works.

what about the other question. can you advice?

"another question, what is the meaning of configuring the "ip address" command inside tunnel configuratiom mode? in what situations this ip is used? cause as much as i know the tunnle using the ip address on the interface which through it passes. "

Richard Burts Wed, 03/25/2009 - 05:13

Alon

In general we configure an IP address on an interface to activate processing of IP on that interface. That principle applies to the tunnel interface. You would configure an IP address on the tunnel interface to activate processing of IP on the tunnel.

Note that if you do not configure an IP address on the tunnel interface then the tunnel can come up and be active but it will not pass IP traffic through the tunnel. Back in times when there were multi protocol networks I would sometimes configure a tunnel to pass IPX traffic from one part of the network to another part of the network. In that case the tunnel did not have an IP address but did have an IPX address.

You ask when you would use the IP address that you configure on the tunnel and one example is that if you want to run a dynamic routing protocol like OSPF over the tunnel then the tunnel must have an IP address configured and OSPF must have a network statement that matches the IP address of the tunnel interface.

HTH

Rick

AlonStyle Wed, 03/25/2009 - 22:51

Thanks for the quick answer,

so, as i understand, in my case, the addresses of the tunnel's endpoints have no meaning and does not even have to be in the same subnet?

Actions

This Discussion