Call Manager 7.0(2) phone firmware

Unanswered Question
Mar 25th, 2009
User Badges:

Hello,


Just a little back ground here. I upgraded CM to 7.0(2) over last weekend. A week before I did the upgrade, I upgraded all the phone firmware to 8-4-4 and upgraded all the voice gateways to 12.4(22)T. All phones functioned fine with the new firmware along with the gateways. Once the upgrade was done on CM, it's default firmware was set to 8-4-3 so it downgraded all the phones. I would like to know how to upgrade just a few phones back to 8-4-4 without doing all of them. How do I do that? The reason I want to do this is echo on incoming calls from customers. There wasn't echo when we were on 8-4-4. This started after the phones were downgraded to 8-4-3. Can the firmware cause echo?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Rob Huffman Wed, 03/25/2009 - 07:38
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hey Troy,


Well, it sounds like your upgrade went quite nicely except for this Hiccup.Good stuff!


When you go to install the new Firmware (8.4.4) you can try it on a small number of phones first by selecting the new loads via the IP Phone Device Configuration page. Once you are satisfied with the new version you can change it for the remaining phones via Device Defaults (just a thought :)


Cheers!

Rob


troymaki Wed, 03/25/2009 - 07:51
User Badges:

Hi Rob,


Yeah, it went pretty good considering I've never done one before. I just want to be clear about upgrading a few phones. For example, if I just wanted to do my phone, I would open CM Administration, Device, Phone, Search for my phone. On the 'Phone Configuration' screen, is the box that I am looking for named "Phone Load Name"? Once I enter the name of the 8-4-4 firmware, I will have to upload that firmware via FTP into CM, right? The last time I did that, it auto updated the default load to the version I uploaded. Can I just change it back to the 8-4-3 or does that version get removed when I upload the new one?


Thanks again.

Troy

troymaki Wed, 03/25/2009 - 09:16
User Badges:

I got it figured out. I was on the right path. So far, I have upgraded a couple phones and they haven't said anything about echo. We placed about 20 test calls from cell phones and it never echoed. Does it make sense that the phone firmware would be related to echo?

Rob Huffman Wed, 03/25/2009 - 09:27
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hey Troy,


Good work! It is possible that the Firmware could have something to do with echo (anything is possible) I have seen improvements to echo issues usually related to the Gateway IOS (and related DSP versions). It seems like a pretty safe bet to go with 8.4.4 for the phone firmware :)


Cheers!

Rob

troymaki Wed, 03/25/2009 - 10:52
User Badges:

Hey Rob, is there a recommended version of IOS to run on my 2811's with CM 7.0(2)? I went with 12.4(22)T because that is what I have on my 1861's. It was recommended to me by TAC at some point a few months back to fix issues with those. I couldn't find any documentation about what IOS works best with CM 7.0(2), only minimum version requirements. Again, thanks for your help.


Troy

Rob Huffman Wed, 03/25/2009 - 14:11
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hey Troy,


I don't believe there are any "specific" recommendations for IOS versions in relation to CUCM versions, not that I've ever seen anyways :) The IOS in question that had some serious echo problemes related to the DSP versioning was around 12.4(9) so I don't see that as the problem. I will do some more digging here to see if anything pops up for 12.4(22)T and "echo..echo...echo....echo"


Cheers!

Rob

Tommer Catlin Thu, 03/26/2009 - 06:56
User Badges:
  • Green, 3000 points or more

It's probably not the phone firmware, but the phone firmware that comes with 7 needs to be upgraded anyways. We found the other week, the echo is caused by G.722 turned on by default now. We have no idea why this like this, but in the Enterprise settings, G.722 is turned on by default. If (advertised). If you turn it off, all the phones will go back to G.711.

troymaki Thu, 03/26/2009 - 07:12
User Badges:

Interesting. If I do a 'sho voice call stat' on the gateway, the only Codec that shows up is g711ulaw. I checked the CM and "Advertise G.722 Codec' is enabled. If I look at my phone settings for G.722, it's set to 'Use system default' So does that mean if it's enabled in CM that my phone will use it?

Tommer Catlin Thu, 03/26/2009 - 07:14
User Badges:
  • Green, 3000 points or more

Yeah, but on the IP Phone, hit the "?" twice you see the phone stats. I think you will see G.722 in use. I'd disable the G.722 in the enterprise. You will notice the difference.

troymaki Thu, 03/26/2009 - 07:26
User Badges:

Ok, I made an internal call and verified that it is using G.722. If I make an outbound call to my cell, it uses G.711u. We haven't had any complaints about echo from IP phone to IP phone. It only happens to calls from or to the outside. I'm not sure if turning that off would make a difference on outbound calls. I have no idea, so please let me know if it will help. I'm not a VoIP guy by any stretch, but I have been thrown into this and trying to learn.

Tommer Catlin Thu, 03/26/2009 - 07:32
User Badges:
  • Green, 3000 points or more

You could, change the enterprise voice parameter to disable, then reboot your test phone and make a call outbound to see if it changes it. The last 7.0x I did, did not have any echo from what I recall. The customer actually complained because it sounded too good..??? whacko. anyways...



I suspect the G.722 doing something with the echo. We had the same issue and with echo and that fixed it by turning it off.



troymaki Thu, 03/26/2009 - 07:38
User Badges:

Ok, I'll give it a try. Do you know if changing it to disable will auto-restart all the phones or will it tell me to manually restart them? There was something that I changed with the directories lookup and it never told me that it was going to reset the phones, it just did it. I can't have that happen again.

Tommer Catlin Thu, 03/26/2009 - 07:48
User Badges:
  • Green, 3000 points or more

No, the phones should not restart. You can change the setting and it should not reboot the phones. The phones codec is downloaded upon restart. Device information is only downloaded upon restart.


Like the screen says, for the parameter to take effect, a restart of the phones is required. My interpretation is that you will have to restart the phones.


I just toggled on/off on my system and my IPC did not reboot. So I think you are safe.

troymaki Thu, 03/26/2009 - 08:37
User Badges:

Thanks! I am waiting on replies from 3 remote locations to see if they are still having echo issues. If so, I am going to turn off G.722 over lunch and reset all the phones.

Tommer Catlin Thu, 03/26/2009 - 08:39
User Badges:
  • Green, 3000 points or more

just remember those places need to have the phone restarted so they get the new device configs.

troymaki Tue, 03/31/2009 - 06:01
User Badges:

Here is an update. I never did turn off G.722 on any of the phones. I upgraded the phones back to 8-4-4 at all locations and the echo has stopped. I am still running 12.4(22)T on the 3 remote gateways. I did downgrade the IOS on the gateway at my location per TAC. I am going to go back to 12.4(22)T this weekend and run with it next week. I'll follow up with results.

Actions

This Discussion