IOS upgrade & LMS

Unanswered Question
Mar 25th, 2009

Hi,


I am trying to push software using CiscoWorks. It fails because there is not enough space

on flash. I would like to have CiscoWorks, as part of the job, erase the existing software

to make room for the new software, as then, there would be room.


Is this possible, what are the recommendations?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Joe Clarke Wed, 03/25/2009 - 22:02

RME will automatically detect when an erase is required. It sounds like you may be hitting a ne wbug I found. Please post a set of screenshots shwoing each step of your SWIM job configuration.

andrewswanson Thu, 06/18/2009 - 07:22

hello


having the same problems using cisco lms 3.0.1 to upgrade ios on catalyst 2950s - currently using lms versions:


1. CiscoWorks Common Services 3.1.1

2. Campus Manager 5.0.5 18

3. CiscoView 6.1.7 14

4. CiscoWorks Assistant 1.0.1 14

5. Device Fault Manager 3.0.5 18

6. Internetwork Performance Monitor

7. Integration Utility 1.7.1 14

8. LMS Portal 1.0.1 14

9. Resource Manager Essentials

10. Health and Utilization Monitor


i've tried both the By Devices Basic and Advanced methods of software distribution but it always fails with the error:


Catastrophic - SWIM1200:Selected Flash partition requires minimum (8 MB) to upgrade selected software/image.

Select a different Flash partition for upgrading the image



used to (last time was january 2009) be able to upgrade 2950s ok - there would be warnings about flash size but the upgrade would go ahead ok - flash would be wiped and the new ios installed.

i can still upgrade ios on devices like 3750s where space in flash isn't an issue.


can't recall what upgrades i've applied since i last successfully upgraded a 2950 - applied all latest patches today as well.


any ideas?


thanks

andy

andrewswanson Fri, 06/19/2009 - 01:10

found a work around - problem happens only with IOS images added to the Software Repository using the Cisco.com Image Source option.


IOS images (the same ones as were downloaded using the Cisco.com option) that are manually downloaded from Cisco and added to the Software Repository using the File System Image Source option work fine.


when upgrading an IOS with an image added via the File System, the Software Distribution wizard step "3 View Verification" now displays a Warning rather than an Error as shown in the pdf i posted earlier.


cheers

andy



Joe Clarke Fri, 06/19/2009 - 08:55

Yes, you are hitting bug CSCsu49349. Your workaround is more or less correct. The idea is to change the image attributes to specify a smaller required flash size. Since you imported from the file system, these attributes do not get filled in.


This bug is fixed in LMS 3.2 which is now available from http://www.cisco.com/upgrade/ for contracted users.

andrewswanson Wed, 06/24/2009 - 00:41

thanks for that - will continue with the workaround as i don't think we are licensed for 3.2

cheers

andy

Actions

This Discussion