iprouting issue

Answered Question
Mar 26th, 2009
User Badges:

I am not sure if this is a bug

but everytime I enable

ip routing the switch Locks up on me

and I have to reboot it to get it back up.


Here is the model type and

IOS I tried it on both

with same results



WS-C3560-24TS-S

Version 12.2(37)SE1


3560-ipbasek9-mz.122-37.SE1

c3560-ipservicesk9-mz.122-37.SE1

Correct Answer by Yudong Wu about 8 years 1 month ago

In your current configuration, did you use "ip default-gateway x.x.x.x" to configure the default gateway? If yes, after you enable "ip routing", the switch won't know it's default gateway any more. That's why you could not access the switch.


If possible, try to add "ip route 0.0.0.0 0.0.0.0 " first before you enable "ip routing".

If not possible, you have to telnet/SSH to the switch from its default gateway so that you can still have access to the switch after you enable "ip routing".


HTH.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Yudong Wu Thu, 03/26/2009 - 21:34
User Badges:
  • Gold, 750 points or more

If you enable "ip routing", make sure to use "ip route 0.0.0.0 0.0.0.0 x.x.x.x" to configure your default gateway instead of using "ip default-gateway" command.

jfeo Thu, 03/26/2009 - 21:39
User Badges:

I can't

when I issue the command

IP ROUTING


The switch locks up

Yudong Wu Thu, 03/26/2009 - 21:42
User Badges:
  • Gold, 750 points or more

Well, if you don't have console to the box, you can telnet to this switch from its default gateway.

jfeo Thu, 03/26/2009 - 21:50
User Badges:

Here is my problem

The switch is already configured

I am ssh into it from a remote site



I want to enable routing the switch


As soon as I issue the command

IP ROUTING

The switch locks up and I have to get someone to reboot it.

Yudong Wu Thu, 03/26/2009 - 21:59
User Badges:
  • Gold, 750 points or more

In your current configuration, did you use "ip default-gateway x.x.x.x" to configure the default gateway? If yes, after you enable "ip routing", the switch won't know it's default gateway any more. That's why you could not access the switch.


If possible, try to add "ip route 0.0.0.0 0.0.0.0 " first before you enable "ip routing".

If not possible, you have to telnet/SSH to the switch from its default gateway so that you can still have access to the switch after you enable "ip routing".


HTH.

jfeo Thu, 03/26/2009 - 22:03
User Badges:

ok I Understand now

Thank you for your help

Correct Answer
Yudong Wu Fri, 03/27/2009 - 09:11
User Badges:
  • Gold, 750 points or more

In your current configuration, did you use "ip default-gateway x.x.x.x" to configure the default gateway? If yes, after you enable "ip routing", the switch won't know it's default gateway any more. That's why you could not access the switch.


If possible, try to add "ip route 0.0.0.0 0.0.0.0 " first before you enable "ip routing".

If not possible, you have to telnet/SSH to the switch from its default gateway so that you can still have access to the switch after you enable "ip routing".


HTH.

Actions

This Discussion