How to start with Cisco Works

Unanswered Question
Mar 27th, 2009
User Badges:

I have installed a Cisco works on Windows Server 2003 machine but when I open Cisco works it doesn't start. What is the path of Cisco works to enter in Internet explorer?. Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.6 (13 ratings)
Loading.
Sven Hruza Fri, 03/27/2009 - 03:08
User Badges:
  • Bronze, 100 points or more

The path is for HTTP:


http://<>:1741


or instead of the servername you can use the ip address.

reg_cisco Fri, 03/27/2009 - 03:56
User Badges:

I did what you say and doesn't works by ip neither by name

It is a virtual machine with VMWare

Sven Hruza Fri, 03/27/2009 - 04:04
User Badges:
  • Bronze, 100 points or more

Are all services running?


You can check this by using "pdshow" on the CLI of the server.


If they are not running you can start them with

"net start crmdmgtd"

and stop them (if necessary) with

"net stop crmdmgtd".

Sven Hruza Fri, 03/27/2009 - 04:48
User Badges:
  • Bronze, 100 points or more

If the state is "running normally" or "Program started - No mgt msgs received" the process should be okay.


I think the main task is that your apache is not running!


Process= Apache

State = Never started

Pid = 0

RC = 0

Signo = 0

Start = N/A

Stop = Not applicable

Core = Not applicable

Info = Not applicable,


Use the command "net start crmdmgtd" to start all the processes!

reg_cisco Fri, 03/27/2009 - 05:29
User Badges:

I paste the command output:


The requested service has already been started

More help is available by typing net helpmsg 2182


and Cisco works doesn't works

reg_cisco Fri, 03/27/2009 - 06:29
User Badges:

I tried what you say and it continues not working

Sven Hruza Fri, 03/27/2009 - 07:05
User Badges:
  • Bronze, 100 points or more

Are all processes started now?


If yes, is it possible to start the webinterface by using the shortcut on the servers desktop?


If not, do you have an active firewall on the server or are some needed ports not available?

An overview for the ports you should find in the install guide.

reg_cisco Mon, 03/30/2009 - 04:59
User Badges:

Now Cisco works it is working. I uninstalled it a then installed it but know I have a lot of problems. I don't know how to start to work with it.

Sven Hruza Mon, 03/30/2009 - 09:25
User Badges:
  • Bronze, 100 points or more

Okay....

I think it is a good idea to read the following white paper:


http://www.cisco.com/warp/public/cc/pd/wr2k/lnmn/prodlit/cwsdg_dg.pdf


It's a deployment guide where you can find informations about how to configure your devices for management, how the discovery works and so on.


I think there are a lot of white papers in the DVD or look on the server under \\ROOT\CSCOpx\htdocs\help.

reg_cisco Tue, 03/31/2009 - 02:50
User Badges:

Following the document of deployment guide I configure snmp server in one Cisco Catalyst 3750 but now when I go to Cisco RME in Cisco works this error message appears License Server/Deamon Manager is down. Please check license.log for more information.


Always when I open web browser this error is showed:


Server Not Ready

Please wait..... System is still coming up. You will be redirected to login page soon

Sven Hruza Tue, 03/31/2009 - 03:12
User Badges:
  • Bronze, 100 points or more

What is the input of the license.log? Did you check it?


Did you install the valid license or a trial-license (if such a license is available) when you installed the application?


The process to manage your devices is the following:

1. configure the snmp parameters on the devices (snmp-server community RO + RW)

1.1 Secure your community by using ACLs!

2. configure the Discovery process on Common Services for automatically discovery of new devices.

But you can manually add a device in the Device Manager on CS.

3. After the basic discovery on CS you can add the device to other modules like RME or DFM.

reg_cisco Wed, 04/01/2009 - 01:06
User Badges:

I can-t access Device discovery and CS. It shows me an error

Sven Hruza Wed, 04/01/2009 - 01:46
User Badges:
  • Bronze, 100 points or more

I think you have a bigger issue with your system.


If you can't access CS, some processes are still not working.


Do you have support from a provider?

Sven Hruza Wed, 04/01/2009 - 02:00
User Badges:
  • Bronze, 100 points or more

Okay....


What error is shown in the browser?

Are all processes started? Is it possible to access another module from ciscoworks, RME or DFM?

If not I think you have a problem with your apache webserver...

reg_cisco Wed, 04/01/2009 - 02:14
User Badges:

I configure all Cisco works processes in automatic and started and now I think I can access Cisco works portal without problems.

I have a problem of something is misconfiugred when I try to discovery devices. The following error is showed:

Discovery configurations is not proper. Please configure the modules and other settings and try again.

Sven Hruza Wed, 04/01/2009 - 03:07
User Badges:
  • Bronze, 100 points or more

Okay, that sounds not so bad ;-)


Go to CS -> Device and Credentials -> Device Discovery -> Discovery settings -> configure


In the first step you can select the modules you want to use. I think "CDP" is very useful and "Routing table" is useful for jumping WAN lines.


In the second step configure "global seed devices" as a starting point for discovery. This should be a core switch or a main router.


In the third step you have to configure the SNMP read communities for your networks as they are configured on the devices. You can use wildcards like:

10.[10-20].*.* or 192.168.1.*


Then you can configure filters if you have some networks you don't want to discover (exclude) or you want to discover (include). You can use wildcards as in the SNMP section.


In the global settings you can select which IP addresses you want to use. I am using loopback for example where it is possible. Another good working way is to "resolve by name" if you have a proper DNS for your devices.


In the last step you will see a summary. Click "Finish".


Then you can start your discovery once again.


Good luck!



reg_cisco Wed, 04/01/2009 - 05:06
User Badges:

Thanks for your information.

Device discovery doesn't work. I enabled snmp in a Cisco Catalyst switch and after I configured Cisco Works with the settings that you say me and in device discovery doesn't appear something.


Sven Hruza Wed, 04/01/2009 - 05:38
User Badges:
  • Bronze, 100 points or more

Please post your SNMP configuration from the device and the the discovery settings if possible.

reg_cisco Wed, 04/01/2009 - 07:31
User Badges:

snmp-server [community string] rw


I can' atteach all discovey settings here. What do you want to know?.

Sven Hruza Wed, 04/01/2009 - 07:50
User Badges:
  • Bronze, 100 points or more

You can check the snmp reachability of the device.

Go to:

Device Diagnostic Tools -> Device Center


There insert the ip address of the device and click "Go".


You will find some tools like "ping" or "snmp walk".


Is it possible to ping the device out of the application? If yes test the snmp reachability by using the snmp walk.


Set your community, v2c as the version and as the starting OID: 1.3.6.1.2.1.1.3


You should get an information about the sys uptime if the device is reachable by snmp.


If this doesn't work you should check firewalls, ACL or something like this.

reg_cisco Wed, 04/01/2009 - 08:31
User Badges:

I can ping with success but snmp failed to get information of the device with the OID trhat you say me.

There is no firewall and neither ACL in device.

Sven Hruza Wed, 04/01/2009 - 08:59
User Badges:
  • Bronze, 100 points or more

Hm...I think a system uptime you should get from every cisco device.


What error message do you get and what device did you test?

reg_cisco Thu, 04/02/2009 - 04:38
User Badges:

I need a list of commands to configure snmp in Cisco Catalyst switch to works with Cisco works. I think the problem is there.

Sven Hruza Thu, 04/02/2009 - 05:04
User Badges:
  • Bronze, 100 points or more

I think you should get a logging message on the switch if LMS takes a false community.


The commands for SNMP:

!

! use an ACL for security

!

access-list 1 permit 10.10.10.1

access-list 2 permit 10.10.10.1

!

! add the communities for RO and RW

!

snmp-server community exampleRead RO 1

snmp-server community exampleWrite RW 2

!

! enable sending traps to the server for DFM

!

snmp-server enable traps

!

! insert the LMS-server as trap destination for DFM

!

snmp-server host 10.10.10.1 version 2c exampleRead

!

! For sending syslog to the LMS RME use:

!

logging trap notifications

logging 10.10.10.1

!

Actions

This Discussion